Bug 129666 - keyboard configuration change
keyboard configuration change
Status: CLOSED DUPLICATE of bug 129638
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-11 13:24 EDT by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-08-11 13:24:52 EDT
Trying to start X with xorg-x11-0:6.7.99.1-1.x86_64 gives the following

(EE) *** ERROR the legacy keyboard driver "keyboard" is deprecated
(EE) *** and has not been compiled into this X server.  It will be removed
(EE) *** in the next release of the Xorg server.
(EE) *** Please consider using the the new "kbd" driver for "Keyboard0".
No core keyboard
 
Fatal server error:
failed to initialize core devices


If we're not going to build the legacy keyboard driver in, the %post
script of the X package needs to munge the config file.
Comment 1 Jeremy Katz 2004-08-11 13:31:16 EDT

*** This bug has been marked as a duplicate of 129638 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.