Bug 1296446 - Race condition in basic and power user portal
Race condition in basic and power user portal
Status: CLOSED DUPLICATE of bug 1296458
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 04:39 EST by Tomas Jelinek
Modified: 2016-01-08 13:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 13:20:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Tomas Jelinek 2016-01-07 04:39:13 EST
There is a race condition in the basic and power user portal. In slower environments if there are both VMs and pools, if the run VM is executed, a NPE is thrown.

It does not do too much damage since it happens only after the command has been sent to server, but the popup with unhandled exception is shown anyway.

Reproduce:
1: have an engine server which is running for some reason quite slow (e.g. slow network between frontend and backend or the engine machine is loaded or something). If the queries return fast it will not reproduce
2: have both VMs and pools
3: click "run" on any VM
4: there is an exception thrown
Comment 1 Einav Cohen 2016-01-08 08:04:23 EST
Tomas - any reason for both this bug and bug 1296458 to be open?
Comment 2 Tomas Jelinek 2016-01-08 13:20:05 EST
Einav - no reason. The bugzilla behaved strange when I have opened this bug and seems I have accidentally opened it more times. Closing this one

*** This bug has been marked as a duplicate of bug 1296458 ***

Note You need to log in before you can comment on or make changes to this bug.