Bug 1296458 - Race condition in basic and power user portal
Race condition in basic and power user portal
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Tomas Jelinek
Petr Matyáš
:
: 1296443 1296446 1306689 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 05:15 EST by Tomas Jelinek
Modified: 2016-02-23 03:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:13:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44363 None None None 2016-01-19 05:02 EST
oVirt gerrit 51487 master ABANDONED userportal: race in user portal main models 2016-01-07 06:05 EST
oVirt gerrit 51496 ovirt-engine-3.6 MERGED userportal: Fix of FE NPE during too fast clicking at list refresh 2016-01-07 10:10 EST

  None (edit)
Description Tomas Jelinek 2016-01-07 05:15:39 EST
There is a race condition in the basic and power user portal. In slower environments if there are both VMs and pools, if the run VM is executed, a NPE is thrown.

It does not do too much damage since it happens only after the command has been sent to server, but the popup with unhandled exception is shown anyway.

Reproduce:
1: have an engine server which is running for some reason quite slow (e.g. slow network between frontend and backend or the engine machine is loaded or something). If the queries return fast it will not reproduce
2: have both VMs and pools
3: click "run" on any VM
4: there is an exception thrown
Comment 1 Tomas Jelinek 2016-01-07 05:18:53 EST
*** Bug 1296443 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Jelinek 2016-01-08 13:20:05 EST
*** Bug 1296446 has been marked as a duplicate of this bug. ***
Comment 3 Petr Matyáš 2016-02-03 09:23:52 EST
Verified on 3.6.3-1
Comment 4 Tomas Jelinek 2016-02-12 03:36:26 EST
*** Bug 1306689 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.