Bug 1296451 - Hand pointer with no clickable links in tenant summary page
Hand pointer with no clickable links in tenant summary page
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity low
: GA
: 5.6.0
Assigned To: lgalis
Aziza Karol
ui:tenant
: ZStream
: 1296647 (view as bug list)
Depends On:
Blocks: 1296663
  Show dependency treegraph
 
Reported: 2016-01-07 04:58 EST by Aziza Karol
Modified: 2016-06-29 11:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296647 1296663 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:25:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
akarol: automate_bug-


Attachments (Terms of Use)
hand pointer (90.05 KB, image/png)
2016-01-07 04:58 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2016-01-07 04:58:23 EST
Created attachment 1112403 [details]
hand pointer

Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.0.20151219144653_653c0d4 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to access->control tenants and create a new tenant
2.check "Groups in this tenant" in the tenant summary page and view the group
3.

Actual results:
Hand pointer with no clickable links when trying to view group in the tenants. see attached screenshot

Expected results:


Additional info:
Comment 2 Harpreet Kataria 2016-01-11 14:29:04 EST
Laura,


Can you look into this one, issue here is that the group tenant is pointing to is not in the tree as it is a hidden group. I think you had fixed something similar somewhere else to not show group if group_type is tenant or it's a hidden group.

Let me know if you have questions.

~Harpreet
Comment 5 CFME Bot 2016-01-11 17:36:17 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/4a0bc348cc2d01f62f295282bc130bc4834751b0

commit 4a0bc348cc2d01f62f295282bc130bc4834751b0
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Mon Jan 11 16:45:18 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Mon Jan 11 16:45:58 2016 -0500

    Tenant groups should not be displayed in the Tenant details page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296451

 app/views/ops/_rbac_tenant_details.html.haml     |  2 +-
 spec/controllers/ops_controller/ops_rbac_spec.rb | 12 ++++++++++++
 2 files changed, 13 insertions(+), 1 deletion(-)
Comment 6 Harpreet Kataria 2016-01-12 11:00:10 EST
*** Bug 1296647 has been marked as a duplicate of this bug. ***
Comment 7 CFME Bot 2016-01-12 14:29:56 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=769ceffe9eb8e9800086478165274577a1e97501

commit 769ceffe9eb8e9800086478165274577a1e97501
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Mon Jan 11 16:45:18 2016 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Tue Jan 12 11:04:31 2016 -0500

    Tenant groups should not be displayed in the Tenant details page
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296451
    (cherry picked from commit 4a0bc34)

 app/views/ops/_rbac_tenant_details.html.haml     |  2 +-
 spec/controllers/ops_controller/ops_rbac_spec.rb | 12 ++++++++++++
 2 files changed, 13 insertions(+), 1 deletion(-)
Comment 8 Aziza Karol 2016-04-19 05:53:48 EDT
Tenant groups is not displayed in the Tenant details page.

Verified:5.6.0.1-beta2.20160413141124_e25ac0e
Comment 10 errata-xmlrpc 2016-06-29 11:25:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.