Bug 1296611 - Rebalance crashed after detach tier.
Rebalance crashed after detach tier.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
:
Depends On: 1296134
Blocks: 1297309
  Show dependency treegraph
 
Reported: 2016-01-07 11:24 EST by Nithya Balachandran
Modified: 2016-06-16 09:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296134
: 1297309 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:53:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-08 00:08:42 EST
REVIEW: http://review.gluster.org/13193 (cluster/dht : Rebalance process crashes due to double fd_unref) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2016-01-08 03:26:17 EST
REVIEW: http://review.gluster.org/13193 (cluster/dht : Rebalance process crashes due to double fd_unref) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Vijay Bellur 2016-01-11 00:19:34 EST
COMMIT: http://review.gluster.org/13193 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 36fcaf275952202ce3f1e621d3b3a34d58054c99
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Jan 8 10:36:37 2016 +0530

    cluster/dht : Rebalance process crashes due to double fd_unref
    
    The dst_fd was being unrefed twice in case the call
    to __dht_rebalance_create_dst_file failed.
    
    Change-Id: I56c5aff7fa3827887e67936b8aa1ecbd1a08a9e9
    BUG: 1296611
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13193
    Reviewed-by: Susant Palai <spalai@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:53:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.