Bug 1297309 - Rebalance crashed after detach tier.
Rebalance crashed after detach tier.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.7
All Unspecified
high Severity high
: ---
: ---
Assigned To: Nithya Balachandran
: Triaged
Depends On: 1296134 1296611
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 02:24 EST by Nithya Balachandran
Modified: 2016-04-19 03:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296611
Environment:
Last Closed: 2016-04-19 03:52:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-11 02:31:43 EST
REVIEW: http://review.gluster.org/13212 (cluster/dht : Rebalance process crashes due to double fd_unref) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2016-01-24 21:28:26 EST
COMMIT: http://review.gluster.org/13212 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4e9ef2cc5ca8f5568bfb6328a756f4a824f69639
Author: N Balachandran <nbalacha@redhat.com>
Date:   Mon Jan 11 12:55:03 2016 +0530

    cluster/dht : Rebalance process crashes due to double fd_unref
    
    The dst_fd was being unrefed twice in case the call
    to __dht_rebalance_create_dst_file failed.
    
    > BUG: 1296611
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/13193
    > Reviewed-by: Susant Palai <spalai@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    > Tested-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit 36fcaf275952202ce3f1e621d3b3a34d58054c99)
    
    Change-Id: I56c5aff7fa3827887e67936b8aa1ecbd1a08a9e9
    BUG: 1297309
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13212
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Kaushal 2016-04-19 03:52:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.