Bug 1296646 - Unable to set group ownership to "No Group"
Unable to set group ownership to "No Group"
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.5
Assigned To: Keenan Brock
Ramesh A
: ZStream
Depends On: 1296402
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 13:22 EST by John Prause
Modified: 2016-07-26 11:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
In a previous version of CloudForms, a template's group ownership could not be set to "No Group", even though the option was available in the user interface. This happened because CloudForms requires a template to belong to at minimum one group, and would thus assign the tenant's default group to a template. With this fix, the "Select a Group" dropdown menu no longer contains "No Group" as an option. Only groups and tenants are listed and available to be assigned.
Story Points: ---
Clone Of: 1296402
Environment:
Last Closed: 2016-07-26 11:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove no group from ui (899 bytes, patch)
2016-05-10 17:04 EDT, Keenan Brock
no flags Details | Diff

  None (edit)
Comment 2 Keenan Brock 2016-01-27 12:32:18 EST
The customer wants to clear the group to solve a problem.
Please share what the problem is and I will do my best to get you
a solution (not a hack).
Comment 3 Keenan Brock 2016-01-27 12:33:10 EST
primary bug was downgraded. downgrading this as well.
Comment 5 CFME Bot 2016-02-25 10:20:36 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8b3d78c54cc743ac6bb26cc3dbfe298c9776e8f8

commit 8b3d78c54cc743ac6bb26cc3dbfe298c9776e8f8
Author:     Keenan Brock <kbrock@redhat.com>
AuthorDate: Fri Feb 12 11:07:41 2016 -0500
Commit:     Keenan Brock <kbrock@redhat.com>
CommitDate: Tue Feb 23 17:02:53 2016 -0500

    Remove option to assign No Group to a VM
    
    Customer was confused why assigning no group to a VM would assign
    a default group to the VM anyway.
    
    Removed No Group option to avoid confusion.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296646

 app/assets/javascripts/locale/en/app.js                       | 2 +-
 app/assets/javascripts/locale/ja/app.js                       | 2 +-
 app/assets/javascripts/locale/nl/app.js                       | 2 +-
 app/assets/javascripts/locale/zh_CN/app.js                    | 2 +-
 app/controllers/application_controller/ci_processing.rb       | 2 +-
 app/views/shared/views/_ownership.html.haml                   | 5 ++---
 config/locales/en/manageiq.po                                 | 3 ---
 config/locales/ja/manageiq.po                                 | 3 ---
 config/locales/manageiq.pot                                   | 4 ----
 config/locales/nl/manageiq.po                                 | 3 ---
 config/locales/zh_CN/manageiq.po                              | 3 ---
 spec/controllers/application_controller/ci_processing_spec.rb | 2 +-
 12 files changed, 8 insertions(+), 25 deletions(-)
Comment 6 Keenan Brock 2016-05-10 17:04 EDT
Created attachment 1155880 [details]
remove no group from ui

This will hide the set group to none option from the ui
Comment 7 Keenan Brock 2016-05-10 17:06:20 EDT
Please test that the included patch meets your needs

    vmdb
    patch -p1 < 933.patch

--Keenan
Comment 9 CFME Bot 2016-06-13 14:39:16 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f5ba2ad8f10501cddc886ba61c129b9a38126d58

commit f5ba2ad8f10501cddc886ba61c129b9a38126d58
Author:     Keenan Brock <kbrock@redhat.com>
AuthorDate: Fri Feb 12 11:07:41 2016 -0500
Commit:     Keenan Brock <kbrock@redhat.com>
CommitDate: Tue May 10 16:56:52 2016 -0400

    Remove option to assign No Group to a VM
    
    Customer was confused why assigning no group to a VM would assign
    a default group to the VM anyway.
    
    Removed No Group option to avoid confusion.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296646

 app/views/shared/views/_ownership.html.haml | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
Comment 10 CFME Bot 2016-06-13 14:39:50 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=643ed48bd5fd7879f8574086cb9966052dc0e055

commit 643ed48bd5fd7879f8574086cb9966052dc0e055
Merge: a2ec6c5 f5ba2ad
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jun 13 13:37:57 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jun 13 13:37:57 2016 -0400

    Merge branch 'bz_1296646_MR55' into '5.5.z'
    
    Remove option to assign No Group to a VM
    
    https://github.com/ManageIQ/manageiq/pull/6645
    
    Patch did not cleanly apply. took only the haml file change.
    
    
    Customer was confused why assigning no group to a VM would assign
    a default group to the VM anyway.
    
    Removed No Group option to avoid confusion.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296646
    
    See merge request !933

 app/views/shared/views/_ownership.html.haml | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
Comment 11 Keenan Brock 2016-06-14 11:20:31 EDT
all set. clearing needinfo requests
Comment 13 Ramesh A 2016-07-19 05:54:54 EDT
Good to go.  Verified and working fine in 5.5.5.2.20160712144556_629f93b.

"Select a group" dropdown no longer lists "<No Group>" as an option. Only groups and tenants are listed now.
Comment 15 errata-xmlrpc 2016-07-26 11:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html

Note You need to log in before you can comment on or make changes to this bug.