Bug 1296402 - Unable to set group ownership to "No Group"
Unable to set group ownership to "No Group"
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Keenan Brock
Pavol Kotvan
tenant_cfme:group
:
: 1303507 (view as bug list)
Depends On:
Blocks: 1296646
  Show dependency treegraph
 
Reported: 2016-01-07 02:49 EST by Chen
Modified: 2016-07-22 11:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, one was unable to set group ownership to "No Group". This was caused because the dropdown allowed to set no group, but was required to have at least default group. With this fix, select a group dropdown menu does not contain "set group to nil" - only groups and tenants are listed.
Story Points: ---
Clone Of:
: 1296646 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chen 2016-01-07 02:49:03 EST
Description of problem:

Unable to set template group ownership to "No Group"

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-2.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install a CFME 5.5 in VMware vsphere 5.5
2. Set the ownership to "No Group"


Actual results:

The ownership doesn't change, but remain "Tenant [My Company] Access"

Expected results:

The ownership should be set to "No Group"

Additional info:

CFME 3.2 version doesn't encounter this problem. (There is no group called Tenant My Company Access )
Comment 3 Harpreet Kataria 2016-01-07 12:00:59 EST
Looked into this issue, it seems that removing group ownership is not working for all entities. UI code seems to be sending up correct values (in this case nil to remove assigned group for a VM) to model method set_ownership in app/models/mixins/ownership_mixin.rb. Tried following commands in UI to verify that group is not getting cleared out for a VM, these commands might be helpful to write a spec test to recreate the issue:

vm = Vm.first
vm.miq_group.name
vm.miq_group=nil
vm.save
vm.miq_group.name

Let me know if more info on this is needed.

~Harpreet
Comment 4 Keenan Brock 2016-01-07 12:48:06 EST
This will not work.

A vm has to have both a group and tenant owner.
If there is not group, then it will just assigned the tenant's default group.
Since there are no users in the tenant's default group, there will be no changes to access.

What are you trying to do?
Why do you want no group?
Comment 5 Keenan Brock 2016-01-07 13:05:55 EST
Given: We need to fix the ui and remove "Set group to no group".

But what I want to know is why the customer wants to set it to no group?
What are they hoping to achieve?

I'm hoping we can understand this and potentially update the UI
to fix any confusion that we are causing the customers.
Comment 7 Keenan Brock 2016-02-08 12:03:37 EST
*** Bug 1303507 has been marked as a duplicate of this bug. ***
Comment 8 Keenan Brock 2016-05-18 13:44:31 EDT
This has been on master since before 5.6 was cut.

To test, you will notice that there should not be a "set group to nil" for a vm anymore.
Comment 12 errata-xmlrpc 2016-06-29 11:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348
Comment 13 Keenan Brock 2016-07-22 11:28:30 EDT
closed and shipped. clearing the need info

Note You need to log in before you can comment on or make changes to this bug.