Bug 129676 - segfault when port specified
Summary: segfault when port specified
Status: CLOSED DUPLICATE of bug 134910
Alias: None
Product: Fedora
Classification: Fedora
Component: ypserv (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-11 19:25 UTC by Monty Walls
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Monty Walls 2004-08-11 19:25:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040721

Description of problem:
# ypserv -p 4005
Segmentation fault


Version-Release number of selected component (if applicable):
ypserv-2.12.1-2

How reproducible:
Always

Steps to Reproduce:
1. ypserv -p 4005 
2. 
3.
    

Actual Results:  segfault

Expected Results:  ypserv to run in background bound to port 4005.  

Additional info:

Comment 1 Edward Grace 2004-09-07 09:58:41 UTC
I too have noticed this problem.  It prevents the (reliable) use of
iptables for filtering ypserv requests.  

ypxfrd does not seem to suffer from this problem.  If it cannot bind
to the given port it complains gracefully.  ypserv doesn't appear to
be even attempting to bind to a port since in debug mode it still dies
before producing any output.

Comment 2 Matthew Foulkes 2004-09-08 09:38:58 UTC
This is a duplicate of bug 123158, which I reported to Red Hat more
than a month ago.  They have not responded yet.  Note that although
"ypserv -p 4005" segfaults, "ypserv --port 4005" works OK (on RHEL3).

Comment 3 Miloslav Trmač 2004-10-14 19:18:36 UTC
Fixed in ypserv-2.13-5. Thanks for your report.

*** This bug has been marked as a duplicate of 134910 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:05:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.