Bug 1296805 - cannot enable internet network access for builds without enabling it in project settings
cannot enable internet network access for builds without enabling it in proje...
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: clime
:
: 1277955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 02:26 EST by Jens Petersen
Modified: 2016-02-04 03:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 03:58:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2016-01-08 02:26:36 EST
Description of problem:
Earlier one could enable network access on a per build basis
without having to enable it in the projects settings.

ie now if internet access is not enabled in settings then
setting it for a build does nothing.  I kind of hope this is a bug...
since for some projects it is useful to be able to only enable
it only for some specific builds.

How reproducible:
100%

Steps to Reproduce:
1. for a project with net access disabled in its settings
2. build a package (that needs net access) with internet access enabled

Actual results:
2. fails due to no net access (project internet setting seems to override)

Expected results:
2. expect build settings to override project settings

Additional info:
I believe this change of behaviour happened towards the end of 2015.

If project setting needs to be set for any kind of net access
then no point to show the option in the build page if it is disabled
for the project (or it could be renamed to "Disable internet access";).

I liked the original behaviour better: where one could enable net access
per builds even when it was disabled for the project.

Alternatively one could have an additional checkbox in project Settings
to set the project default of whether net access is enabled by default
for builds or not.
Comment 1 clime 2016-01-28 01:35:09 EST
Fixed by 66caa7fccc
Comment 2 clime 2016-01-28 01:52:24 EST
*** Bug 1277955 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Suchý 2016-02-03 07:28:40 EST
Code with this fix is currently deployed on copr-fe-dev.cloud.fedoraproject.org. You can test it there before it will be deployed to production.
Comment 4 Miroslav Suchý 2016-02-04 03:58:08 EST
This fix has been just deployed to production.

Note You need to log in before you can comment on or make changes to this bug.