Bug 1296940 - Include ntp package in RHGS container image [NEEDINFO]
Include ntp package in RHGS container image
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS Container Converged 1.0
Assigned To: Mohamed Ashiq
Prasanth
: ZStream
: 1296942 (view as bug list)
Depends On:
Blocks: 1332128
  Show dependency treegraph
 
Reported: 2016-01-08 08:50 EST by Shruti Sampat
Modified: 2016-10-14 09:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 09:38:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ssampat: needinfo? (asrivast)


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2016-01-08 08:50:07 EST
Description of problem:
-----------------------

Package ntp is required to synchronize time across servers in a cluster. Lack of synchronization between servers can cause failures in geo-replication. It would be better to have ntp installed in the container by default.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
rcm-img-docker01.build.eng.bos.redhat.com:5001/rhgs3/rhgs-server-rhel7:3.1.2-5

Actual results:
---------------
RHGS container image does not contain ntp package.

Expected results:
-----------------
RHGS container image should contain ntp package.
Comment 2 Shruti Sampat 2016-01-08 08:57:18 EST
*** Bug 1296942 has been marked as a duplicate of this bug. ***
Comment 14 Mike McCune 2016-03-28 19:08:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 15 Mohamed Ashiq 2016-03-31 03:41:14 EDT
Have added ntp in the image, now have to specify -v /etc/localtime:/etc/localtime:ro in data container to get the timezone synced with the host.
Comment 20 Prasanth 2016-06-06 02:18:21 EDT
ntp package is now included in RHGS container image:

#######
[root@dhcp42-221 /]# cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 3 (Container)

[root@dhcp42-221 /]# rpm -qa |grep ntp               
ntpdate-4.2.6p5-22.el7_2.1.x86_64
ntp-4.2.6p5-22.el7_2.1.x86_64
#######

Moving it to Verified.

Note You need to log in before you can comment on or make changes to this bug.