Bug 1297030 - UI: Form buttons are not visible on Automate/Simulation screen
UI: Form buttons are not visible on Automate/Simulation screen
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Eric Winchell
amogh
ui:button
: ZStream
Depends On:
Blocks: 1298685
  Show dependency treegraph
 
Reported: 2016-01-08 14:20 EST by Harpreet Kataria
Modified: 2016-06-29 11:26 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298685 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:26:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dhalasz: needinfo+


Attachments (Terms of Use)
Screenshot of Automate/Simulation screen (65.46 KB, image/png)
2016-01-08 14:22 EST, Harpreet Kataria
no flags Details
After Simulation buttons not visible (470.98 KB, image/png)
2016-01-08 15:00 EST, mkanoor
no flags Details
scrollbar_not_present_56 (64.93 KB, image/png)
2016-04-25 15:17 EDT, amogh
no flags Details
scrollbar_not_present_upstream (68.96 KB, image/png)
2016-04-25 15:18 EDT, amogh
no flags Details
scrollbar_displayed (61.31 KB, image/png)
2016-05-12 14:52 EDT, amogh
no flags Details

  None (edit)
Description Harpreet Kataria 2016-01-08 14:20:45 EST
Description of problem: Form buttons at the bottom of left panel are not visible on Automate/Simulation screen


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Go to Automate/Simulation screen, form button in the left panel are not visible, had to make browser Full Screen in order to see form buttons to submit/cancel changes.
2.
3.

Actual results: Form buttons are not visible


Expected results: Form button should be visible without going into Full Screen mode.


Additional info: Looks like browser height issue
Comment 2 Harpreet Kataria 2016-01-08 14:22 EST
Created attachment 1112965 [details]
Screenshot of Automate/Simulation screen
Comment 3 mkanoor 2016-01-08 14:57:11 EST
When we start the Simulate for the first time the buttons (Submit, Reset) are not visible at all till you full screen the browser. After you do the first Submit, we should be seeing the Cancel button but none of the buttons are visible and full screening the browser doesn't help.
Comment 4 mkanoor 2016-01-08 15:00 EST
Created attachment 1112970 [details]
After Simulation buttons not visible
Comment 6 CFME Bot 2016-01-14 12:50:53 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7f7ac4ee10143998fc324dbe0d7887c37bd92990

commit 7f7ac4ee10143998fc324dbe0d7887c37bd92990
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Thu Jan 14 11:37:54 2016 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Thu Jan 14 11:37:54 2016 +0100

    Add .scrollable class to left_div on automate/simulation
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297030

 app/views/miq_ae_tools/_resolve_form.html.haml | 2 ++
 1 file changed, 2 insertions(+)
Comment 7 CFME Bot 2016-01-15 11:30:16 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a07b06b4f4cc847707a4674224488e136c17e5ec

commit a07b06b4f4cc847707a4674224488e136c17e5ec
Merge: a5bcb06 304a079
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 15 11:15:53 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 15 11:15:53 2016 -0500

    Merge branch 'bz-1298685' into '5.5.z'
    
    Add .scrollable class to left_div on automate/simulation
    
    Clean cherrypick from: https://github.com/ManageIQ/manageiq/pull/6179
    https://bugzilla.redhat.com/show_bug.cgi?id=1297030
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1298685
    (cherry picked from commit 7f7ac4ee10143998fc324dbe0d7887c37bd92990)
    
    See merge request !718

 app/views/miq_ae_tools/_resolve_form.html.haml | 2 ++
 1 file changed, 2 insertions(+)
Comment 9 CFME Bot 2016-01-19 22:42:25 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 10 mkanoor 2016-04-21 11:12:48 EDT
David,
This is broken in master.
Thanks,
Madhu
Comment 13 amogh 2016-04-25 15:16:16 EDT
scroll bar is not present in 5.6.0.4-beta2.3.20160421172650_719e256. I don't see the scroll bar in latest upstream master.20160425145713_0e9dc42  either. refer the screenshots. submit/reset buttons are not visible until maximize the browser.
Comment 14 amogh 2016-04-25 15:17 EDT
Created attachment 1150618 [details]
scrollbar_not_present_56
Comment 15 amogh 2016-04-25 15:18 EDT
Created attachment 1150619 [details]
scrollbar_not_present_upstream
Comment 16 Eric Winchell 2016-04-29 08:55:45 EDT
https://github.com/ManageIQ/manageiq/pull/8162
Comment 17 CFME Bot 2016-05-02 09:00:42 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9edaca25e381c118b8a6d4b2898171e2421e9088

commit 9edaca25e381c118b8a6d4b2898171e2421e9088
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Wed Apr 27 12:49:05 2016 -0400
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Wed Apr 27 12:49:05 2016 -0400

    added "scrollable" class back in for simulate screen
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297030

 app/assets/stylesheets/patternfly_overrides.scss | 5 +++++
 app/views/layouts/_content.html.haml             | 2 +-
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 18 amogh 2016-05-12 14:52:15 EDT
verified the issue in 5.6.0.6-beta2.5.20160511140943_ff75fb2. issue not reproducible.
refer the screenshot "scrollbar_displayed"
Comment 19 amogh 2016-05-12 14:52 EDT
Created attachment 1156786 [details]
scrollbar_displayed
Comment 22 errata-xmlrpc 2016-06-29 11:26:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.