Bug 1297351 - Retire vm doesn't work on scvmm provider
Retire vm doesn't work on scvmm provider
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: William Fitzgerald
Jeff Teehan
scvmm:vm:retirement
:
: 1306830 1309825 (view as bug list)
Depends On:
Blocks: 1303097 1309825
  Show dependency treegraph
 
Reported: 2016-01-11 05:11 EST by Taras Lehinevych
Modified: 2016-08-02 21:33 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1303097 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:27:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SCVMM VM status (136.21 KB, image/png)
2016-01-11 05:11 EST, Taras Lehinevych
no flags Details
evm.log (5.96 MB, text/plain)
2016-01-12 06:41 EST, Taras Lehinevych
no flags Details
automation.log (939.77 KB, text/plain)
2016-01-12 06:42 EST, Taras Lehinevych
no flags Details
Model change that I made for Microsoft message (1.70 MB, image/png)
2016-01-21 16:38 EST, William Fitzgerald
no flags Details
Model change that I made for Microsoft message (1.37 MB, image/png)
2016-01-21 16:39 EST, William Fitzgerald
no flags Details

  None (edit)
Description Taras Lehinevych 2016-01-11 05:11:37 EST
Created attachment 1113569 [details]
SCVMM VM status

Description of problem:
When you retire vm on scvmm provider the power state of vm should be off/stopped what means that vm isn't running, however only the status of vm is change to retired. Please take a look at screenshot.

Version-Release number of selected component (if applicable):
5.5.2.0

How reproducible:
Always

Steps to Reproduce:
1. Set up infrastructure provider Microsoft System Center VMM
2. Open any virtual machine
3. Press Lifecycle -> Retire this VM
5. Wait a little bit and check the status of vm and power state 

Actual results:
The status of vm is Retired but power state is on

Expected results:
The power state of vm should be off, also cfme shouldn't allow vm to start/power on

Additional info:
The vm navigation tree update status of vm after reload, so please press on "All VMs & Templates" to update statuses.
Comment 2 Greg McCullough 2016-01-11 11:03:28 EST
Bill - Please work with Tina on this issue and if you need assistance from the provider side contact DanB.
Comment 3 William Fitzgerald 2016-01-11 12:08:48 EST
Taras,

Can you please provide the EVM and Automation logs.

Thanks

Bill
Comment 4 William Fitzgerald 2016-01-11 17:17:32 EST
Could we please also have the appliance information ?
Comment 5 Taras Lehinevych 2016-01-12 06:41 EST
Created attachment 1113909 [details]
evm.log
Comment 6 Taras Lehinevych 2016-01-12 06:42 EST
Created attachment 1113910 [details]
automation.log
Comment 7 Taras Lehinevych 2016-01-12 06:44:37 EST
William, 

Appliance - https://10.16.5.111
VM name - vm_status_retire

The logs are attached.
Comment 8 William Fitzgerald 2016-01-12 17:52:23 EST
I did some testing and I came up with the same results you did. 

I have some questions for you:

1. How did you provision this Vm?
2. Can I retire this Vm?

Thanks

Billy
Comment 9 Taras Lehinevych 2016-01-13 05:15:02 EST
William,

I cloned this vm (vm_status_retire) based on vm called azureone on the provider side (scvmm). Also in my previous tests I provision vm from template "win7pro64 base" and result was the same. 

You can do whatever you need with this vm. 

Regards, 
Taras
Comment 11 William Fitzgerald 2016-01-15 16:34:15 EST
Found multiple problems with retirement of microsoft svcmm provider.

I opened the following provider issues: 

https://bugzilla.redhat.com/show_bug.cgi?id=1299069
https://bugzilla.redhat.com/show_bug.cgi?id=1299071

Currently working on Automate retirement model changes.
Comment 12 William Fitzgerald 2016-01-21 16:38 EST
Created attachment 1117013 [details]
Model change that I made for Microsoft message
Comment 13 William Fitzgerald 2016-01-21 16:39 EST
Created attachment 1117014 [details]
Model change that I made for Microsoft message
Comment 15 CFME Bot 2016-01-29 15:11:24 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b4ceb77b7cf006a983f28e16dab1159434e50afe

commit b4ceb77b7cf006a983f28e16dab1159434e50afe
Author:     Bill Fitzgerald <wfitzger@redhat.com>
AuthorDate: Tue Jan 26 15:10:55 2016 -0500
Commit:     Bill Fitzgerald <wfitzger@redhat.com>
CommitDate: Tue Jan 26 17:10:11 2016 -0500

    Change Infrastructure retirement for Microsoft vendor to call generic
    pre_retirement and check_pre_retirement methods.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297351

 .../VM/Retirement/StateMachines/Methods.class/checkpreretirement.yaml   | 2 ++
 .../VM/Retirement/StateMachines/Methods.class/preretirement.yaml        | 2 ++
 2 files changed, 4 insertions(+)
Comment 17 CFME Bot 2016-02-02 17:21:01 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/49aa23e1817cb9a166240346ae2c2d51d2ab9408

commit 49aa23e1817cb9a166240346ae2c2d51d2ab9408
Author:     Bill Fitzgerald <wfitzger@redhat.com>
AuthorDate: Mon Feb 1 14:48:22 2016 -0500
Commit:     Bill Fitzgerald <wfitzger@redhat.com>
CommitDate: Tue Feb 2 15:51:25 2016 -0500

    Automate - Infrastructure - Added tests for microsoft retirement methods.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297351

 .../method_validation/check_pre_retirement_spec.rb | 34 ++++++++++++++++++++++
 .../unit/method_validation/pre_retirement_spec.rb  | 30 +++++++++++++++++++
 2 files changed, 64 insertions(+)
 create mode 100644 spec/automation/unit/method_validation/check_pre_retirement_spec.rb
 create mode 100644 spec/automation/unit/method_validation/pre_retirement_spec.rb
Comment 18 CFME Bot 2016-02-11 13:27:02 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=acd27fc906b3973642b22a78de2873a788b0c02c

commit acd27fc906b3973642b22a78de2873a788b0c02c
Author:     Bill Fitzgerald <wfitzger@redhat.com>
AuthorDate: Tue Jan 26 15:10:55 2016 -0500
Commit:     Bill Fitzgerald <wfitzger@redhat.com>
CommitDate: Thu Feb 11 11:37:58 2016 -0500

    Change Infrastructure retirement for Microsoft vendor to call generic
    pre_retirement and check_pre_retirement methods.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297351

 .../VM/Retirement/StateMachines/Methods.class/checkpreretirement.yaml   | 2 ++
 .../VM/Retirement/StateMachines/Methods.class/preretirement.yaml        | 2 ++
 2 files changed, 4 insertions(+)
Comment 20 CFME Bot 2016-02-15 10:37:46 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 21 Tina Fitzgerald 2016-03-09 15:32:18 EST
*** Bug 1306830 has been marked as a duplicate of this bug. ***
Comment 22 Tina Fitzgerald 2016-03-09 15:36:36 EST
*** Bug 1309825 has been marked as a duplicate of this bug. ***
Comment 23 Jeff Teehan 2016-03-14 12:59:42 EDT
Using the 5.6 nightly previews, SCVMM VM retirement seems to be working as advertised.  This should go to Verified pretty quickly.  JBT
5.6.0.0-pre-nightly.20160308110502_5e8d65b
Comment 24 Jeff Teehan 2016-04-08 00:30:00 EDT
As before, this is working fine.  Tested using the new force power off functionality and it worked great as well.  Moving to verified using cfme-hyperv-5.6.0.0-nightly-20160404123323-2.x86_64 on https://10.16.6.163/vm_infra/explorer
Comment 26 errata-xmlrpc 2016-06-29 11:27:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.