Bug 1309825 - un-retiring a VM does not unset the retirement_state field in vmdb
un-retiring a VM does not unset the retirement_state field in vmdb
Status: CLOSED DUPLICATE of bug 1297351
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.3
Assigned To: Tina Fitzgerald
Dave Johnson
vm:retirement:rest
: ZStream
Depends On: 1297351 1306830
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 13:53 EST by John Prause
Modified: 2016-03-09 15:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306830
Environment:
Last Closed: 2016-03-09 15:36:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Tina Fitzgerald 2016-02-29 12:51:10 EST
Hi Colin,

Can you validate the information provided in "Additional comment from Tina Fitzgerald on 2016-02-17 14:58:46" resolves the customer reported issue in your environment?

The fixes made by Madhu are not intended to resolve this issue.

Let me know if you have any questions.

Thanks,
Tina
Comment 5 Colin Arnott 2016-03-08 11:19:37 EST
This bug contains current discussion: https://bugzilla.redhat.com/show_bug.cgi?id=1306830T
Comment 6 Tina Fitzgerald 2016-03-09 15:36:10 EST
This issue has been resolved by fixes contained in these tickets:

https://bugzilla.redhat.com/show_bug.cgi?id=1297351
https://bugzilla.redhat.com/show_bug.cgi?id=1299069

The default retirement state machine is designed to remove the VM from the provider and the VMDB. In that case, there would be no VM to unretire.
Comment 7 Tina Fitzgerald 2016-03-09 15:36:36 EST

*** This bug has been marked as a duplicate of bug 1297351 ***

Note You need to log in before you can comment on or make changes to this bug.