Bug 1297499 - CF 3.2: Automation code throwing "0x000... is recycled object" exceptions
CF 3.2: Automation code throwing "0x000... is recycled object" exceptions
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
All All
unspecified Severity urgent
: GA
: 5.5.3
Assigned To: mkanoor
Milan Falešník
: ZStream
: 1304859 (view as bug list)
Depends On: 1297097 1297952
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 11:48 EST by John Prause
Modified: 2017-07-14 11:19 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, the CloudForms Management Engine used a custom mechanism to cache objects sent as references to the Automate methods. However, some of the objects were not cached by the mechanism, resulting in Distributed Ruby (DRb) recycled object errors. DRb has a built-in caching mechanism based on TimerIdConv, so this release of Red Hat CloudForms will use DRb's caching mechanism instead to avoid these errors.
Story Points: ---
Clone Of: 1297097
Environment:
Last Closed: 2016-04-13 14:41:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-02-10 14:53:48 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=eb36c3a6049ceaa2b3bad6e33e837ee93f74c395

commit eb36c3a6049ceaa2b3bad6e33e837ee93f74c395
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Jan 14 17:09:23 2016 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Mon Jan 18 17:03:21 2016 -0500

    Use DRb's builtin caching mechanism
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297499
    
    Previously we have been using our own caching mechanism to
    cache objects sent as references to the Automate Methods. We have
    gotten DRb recycled object errors, since some of the objects which
    were sent as references were not being cached.
    DRb has a builtin caching mechanism based on TimerIdConv, which
    we are starting to use in this PR.
    
    Conflicts:
    	spec/lib/miq_automation_engine/miq_ae_service_spec.rb

 lib/miq_automation_engine/engine/miq_ae_method.rb     | 8 ++++++++
 lib/miq_automation_engine/engine/miq_ae_service.rb    | 2 +-
 spec/lib/miq_automation_engine/miq_ae_service_spec.rb | 9 ---------
 3 files changed, 9 insertions(+), 10 deletions(-)
Comment 4 CFME Bot 2016-02-10 14:54:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=67e439f3b408f4c393a3e98668c702a5240ada13

commit 67e439f3b408f4c393a3e98668c702a5240ada13
Merge: cecc8aa eb36c3a
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Feb 10 14:25:46 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Feb 10 14:25:46 2016 -0500

    Merge branch 'bugzilla_1297499_5_5_z' into '5.5.z'
    
    Use DRb's builtin caching mechanism
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297499
    
    Previously we have been using our own caching mechanism to
    cache objects sent as references to the Automate Methods. We have
    gotten DRb recycled object errors, since some of the objects which
    were sent as references were not being cached.
    DRb has a builtin caching mechanism based on TimerIdConv, which
    we are starting to use in this PR.
    
    Conflicts:
    	spec/lib/miq_automation_engine/miq_ae_service_spec.rb
    
    Not a clean cherry pick for the above file, tests were being removed which didn't exist in 5.5
    Original PR https://github.com/ManageIQ/manageiq/pull/6190
    Only one commit from the PR has been used
    
    See merge request !727

 lib/miq_automation_engine/engine/miq_ae_method.rb     | 8 ++++++++
 lib/miq_automation_engine/engine/miq_ae_service.rb    | 2 +-
 spec/lib/miq_automation_engine/miq_ae_service_spec.rb | 9 ---------
 3 files changed, 9 insertions(+), 10 deletions(-)
Comment 5 Greg McCullough 2016-02-10 15:23:48 EST
*** Bug 1304859 has been marked as a duplicate of this bug. ***
Comment 7 Milan Falešník 2016-03-31 11:12:45 EDT
Checked in 5.5.3.2. After discussion with mkanoor I used the script from [1] which I ran about a dozen times and no error ever happened. The provisioning also works so ...

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1284573
Comment 9 errata-xmlrpc 2016-04-13 14:41:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.