Bug 1297523 - Update Red Hat Access Plugin to work with Rails 4
Update Red Hat Access Plugin to work with Rails 4
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
Unspecified
Unspecified Unspecified
high Severity high (vote)
: Beta
: --
Assigned To: Lindani Phiri
jcallaha
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 13:56 EST by Lindani Phiri
Modified: 2016-07-27 05:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:22:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lindani Phiri 2016-01-11 13:56:02 EST
The foreman (and katello) projects have been updated to use Rails 4.0 in Satellite 6.2

Code changes are required to the Access plugin to ensure that it keeps working after the upgrade.


Per email from Ohad:

Hi,

Just a few headsup - not sure if you are closely following our upstream development.

1. we merged rails 4, there are potentially minor changes, from a quick look it needs to be updated, remove dependency on rails ~> rails 3. , and in the engine remove the += in db/migrate path, and in the routes there is a rails 4 change that needs to be done etc.

2. we merged patternfly/font-awesome etc, I've noticed a few overlap with your vendor directory, most likely can be removed from your plugin?

cheers,
Ohad
Comment 5 jcallaha 2016-04-04 14:04:11 EDT
QA blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1323793
Comment 6 jcallaha 2016-04-14 11:54:03 EDT
Verified Satellite 6.2 Beta Snap 8 compose 1.
Comment 8 errata-xmlrpc 2016-07-27 05:22:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.