Bug 1297539 - Unable to See/Access “My Services” after a Provisioning Event.
Unable to See/Access “My Services” after a Provisioning Event.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Gregg Tanzillo
Jeff Teehan
:
Depends On:
Blocks: 1298703 1299493
  Show dependency treegraph
 
Reported: 2016-01-11 14:39 EST by David Simmons
Modified: 2016-06-29 11:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298703 1299493 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:27:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hotfix for POCs (10.00 KB, patch)
2016-01-19 08:08 EST, Gregg Tanzillo
no flags Details | Diff

  None (edit)
Description David Simmons 2016-01-11 14:39:50 EST
Unable to See/Access “My Services” after a Provisioning Event. 
Environment: 
VSphere 5.5U2
Authentication Active Directory

Tennant 1 = “QA”
Tennant 2 = “Development” 
Service Name “RHEL 7” 
Role(s) = VM and Template Access Restriction = NONE

Steps:
1.	Create a Service Catalog Item – Vmware Provision 
2.	Verify Provisioning Scope is to All 
3.	Log-in as a non admin user (e.g. Clouduser1) under Tennant “Development” 
4.	Log into Services, Launch Service containing RHEL Image. 
Result: 
Service Provisions Vmware image.    However, when clicking “My Services” as the User “Cloud User1” you are unable to see the service.   You can, however, click Infrastructure-VMs and see the VM.   User Permissions reflect as  CloudUser1, Group=cfgroup2 
(Note CFGROUP2 is from Active Directory.  This is mapped to Tennant) .
Comment 2 David Simmons 2016-01-11 15:57:53 EST
More information: 

If I create the Service as the intended Tennant User, "My Services" displays the VM.   When I create the service under the usual "admin" account; "My services" is not displayed. 

Is this by design or a bug?
Comment 3 Kevin Morey 2016-01-11 17:18:55 EST
I can confirm that this is an issue in my environment too.
Comment 5 Gregg Tanzillo 2016-01-18 15:41:25 EST
The issue here is that the service was assigned to the root tenant after is was created. The following PR should address this issue: https://github.com/ManageIQ/manageiq/pull/6209
Comment 6 Gregg Tanzillo 2016-01-19 08:08 EST
Created attachment 1116173 [details]
Hotfix for POCs

Copy bz-1297539-service-under-tenant.tar to /var/www/miq/vmdb and unpack from that directory:

cd /var/www/miq/vmdb
tar -xvf bz-1297539-service-under-tenant.tar

Restart EVM
Comment 8 Jeff Teehan 2016-05-25 12:35:35 EDT
I just reviewed this bug on 5.6.0.7 per some field feedback.  Using the same steps I used for the cloud version of this bug, it's not working.

Logged in as admin
Create new group called QE
Create new user called QEUser in group QE
Logged out and in as QEUser

From Computer\Infrastructure\VM I created a new VM.  It showed up fine.  However, when I expanded VMs and clicked on VMs | Own, the list was blank.

When I do this from Services, I ordered an (azure) catalog item.
Got some coffee

Went to cloud instances and it showed all of them.
Expanded Instances
Selected Instances | Own

It showed only the new instance I had created.

Feel free to use this already configured instance https://10.16.6.106/vm_infra/explorer

user qeuser, password qeuser
Comment 9 Jeff Teehan 2016-05-25 12:38:10 EDT
I want to add that this isn't perhaps entirely the same thing, but it's being blended together in the field, and the fact remains the VM does not contain an owner.  I'm open to the possibility of closing this and adding a new issue, but perhaps it's a quick fix.
Comment 10 Jeff Teehan 2016-05-25 12:44:19 EDT
Here was the 5.5.4 variation of what I think is the same issue.
https://bugzilla.redhat.com/show_bug.cgi?id=1318753  Not clear to me what was changed to fix it.
Comment 11 Jeff Teehan 2016-05-25 12:51:11 EDT
I changed my mind.  This issue is closed per the original description.  And that VM finally did show up in the list under that owner.  My guess is it didn't set the owner until the actual request was verified.

I think it's related to tags instead.  I'll open a new bz in a bit.
Comment 13 errata-xmlrpc 2016-06-29 11:27:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.