This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297586 - Rebase python-setuptools to >1.0
Rebase python-setuptools to >1.0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-setuptools (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
: Rebase
Depends On: 1297522
Blocks: 1297581
  Show dependency treegraph
 
Reported: 2016-01-11 18:22 EST by Nathaniel McCallum
Modified: 2016-01-13 09:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:24:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathaniel McCallum 2016-01-11 18:22:23 EST
Required for rebase of python-cryptography.
Comment 2 Petr Viktorin 2016-01-13 09:13:41 EST
The differences between 0.9.8 (in RHEL 7) and 1.1 (requested here) are, according to [0], some backwards-incompatible changes and not many relevant improvements.

What's the reason python-cryptography can't use 0.9.8? Is it the proxy support in VerifyingHTTPSConn?

Since setuptools are used to install a lot of Python packages, I'm quite worried about the incompatible changes.

[0] https://pythonhosted.org/setuptools/history.html#id146
Comment 3 Nathaniel McCallum 2016-01-13 09:24:38 EST
Turns out this isn't actually needed. They upgraded their requirement to 1.0 to use TLS validation when downloading packages at build time. We don't do that, so it is irrelevant to us. We will patch python-cryptography to use the older version of setuptools.

Note You need to log in before you can comment on or make changes to this bug.