Bug 1297581 - Rebase python-cryptography to 1.3.1
Rebase python-cryptography to 1.3.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-cryptography (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nathaniel McCallum
Namita Soman
: Rebase
Depends On: 1297583 1297584 1297585 1297586 1297587
Blocks: 1249685
  Show dependency treegraph
 
Reported: 2016-01-11 18:07 EST by Nathaniel McCallum
Modified: 2016-11-04 00:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:45:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathaniel McCallum 2016-01-11 18:07:53 EST
New features are needed for the custodia project. We also need to rebase to pick up a crucial bug fix (bug #1249685).
Comment 3 Petr Vobornik 2016-04-14 09:59:22 EDT
Make sure that requires is updated to: 
  python-cffi >= 1.4

To prevent https://fedorahosted.org/freeipa/ticket/5786
Comment 6 Martin Kosek 2016-06-21 04:07:37 EDT
Updating the final rebase version.
Comment 7 Kaleem 2016-09-19 08:30:26 EDT
Verified.

[root@dhcp207-129 ~]# rpm -qi python2-cryptography
Name        : python2-cryptography
Version     : 1.3.1
Release     : 3.el7
Architecture: x86_64
Install Date: Thu 23 Jun 2016 02:07:30 PM IST
Group       : Development/Libraries
Size        : 2581894
License     : ASL 2.0 or BSD
Signature   : (none)
Source RPM  : python-cryptography-1.3.1-3.el7.src.rpm
Build Date  : Wed 11 May 2016 12:53:38 AM IST
Build Host  : x86-030.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : https://cryptography.io/en/latest/
Summary     : PyCA's cryptography library
Description :
cryptography is a package designed to expose cryptographic primitives and
recipes to Python developers.
[root@dhcp207-129 ~]#
Comment 9 errata-xmlrpc 2016-11-04 00:45:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2371.html

Note You need to log in before you can comment on or make changes to this bug.