Bug 1297685 - Deprecation of ipcalculator
Deprecation of ipcalculator
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Simon Clark
ChangeAcceptedF24, SelfContainedChange
:
Depends On: 1340541
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 03:53 EST by Jan Kurik
Modified: 2016-09-29 07:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-29 07:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
simon.richard.clark: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-12 03:53:17 EST
This is a tracking bug for Change: Deprecation of ipcalculator
For more details, see: https://fedoraproject.org//wiki/Changes/ipcalculator

Fedora provides two tools for IP address calculations. That is the ipcalculator and ipcalc. Ipcalculator was geared towards being used by administrators and ipcalc for use with scripts. This changed with Fedora 23 which provided an updated ipcalc tool which can be used both interactively and from scripts. That, and the fact that ipcalculator is not IPv6-ready suggests we should deprecate ipcalculator and keep a single tool for the job, ipcalc.
Comment 1 malaiam 2016-02-23 10:25:37 EST
Hello,

We actually ran into a problem because of the ipcalc tool, the one needed for the scripts.
 
Basically on one of our servers we had our ipcalc tool replaced with another ip calculator tool (http://jodies.de/ipcalc) which prompted some network startup scripts to fail.

Personally, I think the use of the "ipcalc" name for tool needed for by the startup scripts is a bit misleading, since the name, at least in my mind, suggests the interactive tool. 

Making a tool which can be used interactively is a good idea, but making that a tool which the systems depends on is not, because of the example above.

I would hence propose to have the tool needed by the scripts renamed to something less popular and keep the interactive one named ipcalc (that is keep them separate), with the option of the user to replace the interactive one without breaking the system.

If one feels it's not right to post this here, I can try to open another case.

Thanks and regards,
Marius
Comment 2 Nikos Mavrogiannopoulos 2016-02-23 10:56:37 EST
(In reply to malaiam from comment #1)
> Hello,
> 
> We actually ran into a problem because of the ipcalc tool, the one needed
> for the scripts.
>  
> Basically on one of our servers we had our ipcalc tool replaced with another
> ip calculator tool (http://jodies.de/ipcalc) which prompted some network
> startup scripts to fail.
> 
> Personally, I think the use of the "ipcalc" name for tool needed for by the
> startup scripts is a bit misleading, since the name, at least in my mind,
> suggests the interactive tool. 

I am not sure I understand the issue you raise. The ipcalc tool can be used interactively and non interactively the same way as the old ipcalculator. Does this address your concern?
Comment 3 Jan Kurik 2016-02-24 09:25:54 EST
On 2016-Feb-23, we have reached Fedora 24 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-Feb-26 meeting.  Contingency plan for System Wide Changes, if planned for Alpha (or in case of serious doubts regarding Change completion), will be activated.
Comment 4 malaiam 2016-02-29 17:07:11 EST
(In reply to Nikos Mavrogiannopoulos from comment #2)
> (In reply to malaiam from comment #1)
> > Hello,
> > 
> > We actually ran into a problem because of the ipcalc tool, the one needed
> > for the scripts.
> >  
> > Basically on one of our servers we had our ipcalc tool replaced with another
> > ip calculator tool (http://jodies.de/ipcalc) which prompted some network
> > startup scripts to fail.
> > 
> > Personally, I think the use of the "ipcalc" name for tool needed for by the
> > startup scripts is a bit misleading, since the name, at least in my mind,
> > suggests the interactive tool. 
> 
> I am not sure I understand the issue you raise. The ipcalc tool can be used
> interactively and non interactively the same way as the old ipcalculator.
> Does this address your concern?

The problem is a name conflict. Both the interactive ipcalc tool we want to use (http://jodies.de/ipcalc) and the RedHat ipcalc tool have the same name. If one replaces the RedHat ipcalc script with another tool, the RedHat network startup scripts will fail. Making the startup scripts depend on a tool with such a popular name can lead to problems like this one. 

Hence my proposal above to take away the "non interactive" part and put it in some script with a more obscure name which the startup scripts can use easily. Then put the "interactive" part in a tool named anything, ipcalc if you want, as long as removing or renaming this tool won't break the startup scripts.

I hope this clarifies the issue.

Regards,
Marius
Comment 5 Nikos Mavrogiannopoulos 2016-03-01 04:03:14 EST
(In reply to malaiam from comment #4)
> The problem is a name conflict. Both the interactive ipcalc tool we want to
> use (http://jodies.de/ipcalc) and the RedHat ipcalc tool have the same name.
> If one replaces the RedHat ipcalc script with another tool, the RedHat
> network startup scripts will fail. Making the startup scripts depend on a
> tool with such a popular name can lead to problems like this one. 
[...]
> I hope this clarifies the issue.

I believe there is a misunderstanding. The new ipcalc tool included in Fedora23 it is interactive.
Comment 6 malaiam 2016-03-01 04:12:14 EST
(In reply to Nikos Mavrogiannopoulos from comment #5)
> 
> I believe there is a misunderstanding. The new ipcalc tool included in
> Fedora23 it is interactive.

I also think it's a misunderstanding - my issue is not that the new ipcalc tool is or is not interactive. My issue is what happens if I replace it with another one with the same name but with a different behaviour?

Regards,
Marius
Comment 7 Nikos Mavrogiannopoulos 2016-03-01 04:28:24 EST
(In reply to malaiam from comment #6)
> (In reply to Nikos Mavrogiannopoulos from comment #5)
> > 
> > I believe there is a misunderstanding. The new ipcalc tool included in
> > Fedora23 it is interactive.
> 
> I also think it's a misunderstanding - my issue is not that the new ipcalc
> tool is or is not interactive. My issue is what happens if I replace it with
> another one with the same name but with a different behaviour?

I don't really understand what does your issue has to do with this new fedora feature? Could you please elaborate on that?
Comment 8 malaiam 2016-03-01 04:33:52 EST
(In reply to Nikos Mavrogiannopoulos from comment #7)
> (In reply to malaiam from comment #6)
> > (In reply to Nikos Mavrogiannopoulos from comment #5)
> > > 
> > > I believe there is a misunderstanding. The new ipcalc tool included in
> > > Fedora23 it is interactive.
> > 
> > I also think it's a misunderstanding - my issue is not that the new ipcalc
> > tool is or is not interactive. My issue is what happens if I replace it with
> > another one with the same name but with a different behaviour?
> 
> I don't really understand what does your issue has to do with this new
> fedora feature? Could you please elaborate on that?

The issue is with the name of the ipcalc tool combined with startup scripts depending on it. It may very well be that this issue doesn't belong here. I can create a new one if this is not the right place to post here, as I mentioned in my first post.
Comment 9 Nikos Mavrogiannopoulos 2016-03-01 05:06:54 EST
Please use the fedora-devel mailing list for that. This feature does not affect the issue you had (even before the change) or so.
Comment 10 Jan Kurik 2016-04-20 11:01:53 EDT
On 2016-Apr-19 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 24 release. At this point all the Changes not at least in in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 11 Simon Clark 2016-05-08 02:17:25 EDT
I have added an entry to the draft F24 Release Notes to cover this change: https://pagure.io/release-notes/blob/f24/f/en-US/Server_Configuration_Tools.xml

Please would you take a look at the draft text and let me know if anything should be added or changed?
Comment 12 Nikos Mavrogiannopoulos 2016-05-09 05:38:19 EDT
Seems fine to me.

Note You need to log in before you can comment on or make changes to this bug.