Bug 1340541 - Option "-n" does different things on ipcalculator and ipcalc
Option "-n" does different things on ipcalculator and ipcalc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ipcalc (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nikos Mavrogiannopoulos
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1297685
  Show dependency treegraph
 
Reported: 2016-05-27 15:12 EDT by ani.stoicheva
Modified: 2016-05-31 05:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 05:00:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ani.stoicheva 2016-05-27 15:12:44 EDT
Description of problem:

The option "-n" of ipcalc doesn't follow the specification: "ipcalculator has to be obsoleted in Fedora 24 and ipcalc will provide a drop in replacement."

Please, read it in part 1.6 Scope on the following address: https://fedoraproject.org/wiki/Changes/ipcalculator 

In terminal, there's a difference between the output of the command "-n" (ipcalculator -n and ipcalc -n): 
    ipcalculator -n --> Don't display ANSI color codes, while
    ipcalc -n --> Display the network address for the given IP addresses and net-mask.

I think this difference may cause problems to the many users who use the old version of the tool, because they expect other behavior and this may corrupt the result of their code.


Version-Release number of selected component (if applicable): Latest Rowhide


How reproducible: always


Actual results:

The option "-n" does different things in the 2 versions of the tool (ipcalculator and ipcalc).

Expected results:

The ipcalc options should do exactly he same things as ipcalculator's options as it was written that the specification.
Comment 1 Nikos Mavrogiannopoulos 2016-05-30 03:29:48 EDT
(In reply to ani.stoicheva from comment #0)
> Description of problem:
> 
> The option "-n" of ipcalc doesn't follow the specification: "ipcalculator
> has to be obsoleted in Fedora 24 and ipcalc will provide a drop in
> replacement."

Unfortunately that cannot be addressed since the '-n' option of ipcalc is essential for its usage in init scripts.

> Please, read it in part 1.6 Scope on the following address:
> https://fedoraproject.org/wiki/Changes/ipcalculator 

The drop in was with respect to user-visible output (ipcalculator was a tool to be used for interactive status). The tools will not be command line identical. I've removed the "drop in" keyword for clarity.

> I think this difference may cause problems to the many users who use the old
> version of the tool, because they expect other behavior and this may corrupt
> the result of their code.

ipcalc will not provide ipcalculator binary, so a modification of such scripts is anyway required. However do you think that this will be an issue? Is ipcalculator used in scripts?
Comment 2 Alexander Todorov 2016-05-31 05:00:19 EDT
(In reply to Nikos Mavrogiannopoulos from comment #1)
> Is ipcalculator used in scripts?

We can't really know, can we ?

> > Please, read it in part 1.6 Scope on the following address:
> > https://fedoraproject.org/wiki/Changes/ipcalculator 
> 
> The drop in was with respect to user-visible output (ipcalculator was a tool
> to be used for interactive status). The tools will not be command line
> identical. I've removed the "drop in" keyword for clarity.
> 

Thanks for the update, I'm closing this bug now.
I

Note You need to log in before you can comment on or make changes to this bug.