Bug 1297695 - heal info reporting slow when IO is in progress on the volume
heal info reporting slow when IO is in progress on the volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On:
Blocks: 1302553 1303899
  Show dependency treegraph
 
Reported: 2016-01-12 04:10 EST by Krutika Dhananjay
Modified: 2017-01-09 12:37 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302553 1303899 1329344 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-12 04:10:10 EST
Description of problem:

https://www.gluster.org/pipermail/gluster-users.old/2015-December/024568.html :

Here's a snippet of the user's feedback on the thread:

<snip>

...
...
...

Also, it would be great if the heal info command could return faster, 
sometimes it takes over a minute.
...
...
</snip>


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-01 02:28:14 EST
REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-02-01 03:55:52 EST
REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-02-01 04:42:09 EST
REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-02-02 20:44:04 EST
REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2016-02-03 02:00:06 EST
REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Vijay Bellur 2016-02-04 01:58:41 EST
COMMIT: http://review.gluster.org/13326 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b8106d1127f034ffa88b5dd322c23a10e023b9b6
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Feb 1 11:46:08 2016 +0530

    cluster/afr: Fix heal-info slow response while IO is in progress
    
    Now heal-info does an open() on the file being examined so that
    the client at some point sees open-fd count being > 1 and releases
    the eager-lock so that heal-info doesn't remain blocked forever
    until IO completes.
    
    Change-Id: Icc478098e2bc7234408728b54d8185102b3540dc
    BUG: 1297695
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13326
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 7 Niels de Vos 2016-06-16 09:54:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.