Bug 1303899 - heal info reporting slow when IO is in progress on the volume
heal info reporting slow when IO is in progress on the volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On: 1297695
Blocks: 1302553
  Show dependency treegraph
 
Reported: 2016-02-02 06:27 EST by Krutika Dhananjay
Modified: 2016-04-19 03:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1297695
Environment:
Last Closed: 2016-04-19 03:41:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-02-02 06:27:04 EST
+++ This bug was initially created as a clone of Bug #1297695 +++

Description of problem:

https://www.gluster.org/pipermail/gluster-users.old/2015-December/024568.html :

Here's a snippet of the user's feedback on the thread:

<snip>

...
...
...

Also, it would be great if the heal info command could return faster, 
sometimes it takes over a minute.
...
...
</snip>


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-01 02:28:14 EST ---

REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-01 03:55:52 EST ---

REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-01 04:42:09 EST ---

REVIEW: http://review.gluster.org/13326 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 1 Vijay Bellur 2016-02-02 07:03:57 EST
REVIEW: http://review.gluster.org/13333 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-02-04 00:23:53 EST
REVIEW: http://review.gluster.org/13348 (cluster/afr: Fix heal-info slow response while IO is in progress) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-02-04 23:31:59 EST
COMMIT: http://review.gluster.org/13348 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 476abe074b63e4b348b48af9b04a3d27244d7d17
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Feb 1 11:46:08 2016 +0530

    cluster/afr: Fix heal-info slow response while IO is in progress
    
            Backport of: http://review.gluster.org/#/c/13326/
    
    Now heal-info does an open() on the file being examined so that
    the client at some point sees open-fd count being > 1 and releases
    the eager-lock so that heal-info doesn't remain blocked forever
    until IO completes.
    
    Change-Id: I7d4a8aa4de459216408b666894ee7bb42e406547
    BUG: 1303899
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13348
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Kaushal 2016-04-19 03:41:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.8, please open a new bug report.

glusterfs-3.7.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.