Bug 1297723 - We cannot create a schedule for "today"
We cannot create a schedule for "today"
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
high Severity medium
: GA
: 5.6.0
Assigned To: Aparna Karve
Alex Newman
:
Depends On:
Blocks: 1297926
  Show dependency treegraph
 
Reported: 2016-01-12 05:20 EST by Martin Welk
Modified: 2016-06-29 11:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1297926 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:28:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Welk 2016-01-12 05:20:23 EST
Description of problem:
We cannot create a schedule in CFME for "today". 

Version-Release number of selected component (if applicable):
5.5.0.13.20151201120956_653c0d4 

How reproducible:
Create a schedule for a database backup. The schedule should be executed "today".

Steps to Reproduce:
1. In the CFME UI, go to Configure -> Settings -> CFME Region -> Schedules
2. Create a new schedule for database backup (NFS)
3. Set to Run Once or Daily or Hourly
4. Time Zone is (GMT+01:00 Vienna), but happens also, when we choose GMT
5. Choose the Starting Date

Actual results:
First date that we can choose is "today + 1"

Expected results:
We want to be able to chose from "today" on, not tomorrow.

Additional info:
Comment 3 CFME Bot 2016-01-19 19:06:00 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ae0bafa0df08b080916dde911129cc07bd2bb1ae

commit ae0bafa0df08b080916dde911129cc07bd2bb1ae
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Mon Jan 18 15:24:50 2016 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Mon Jan 18 15:24:50 2016 -0800

    User can now pick Today as the start date for schedule creation
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297723

 app/assets/javascripts/controllers/schedule/schedule_form_controller.js | 2 +-
 spec/javascripts/controllers/schedule/schedule_form_controller_spec.js  | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2016-01-19 22:43:34 EST
Detected commit referencing this ticket while ticket status is POST.
Comment 6 Alex Newman 2016-02-01 16:42:52 EST
5.5.2.4.20160127105142_395c086
Comment 7 Alex Newman 2016-04-27 16:24:15 EDT
5.6.0.4-beta2.3.20160421172650_719e256
Comment 9 errata-xmlrpc 2016-06-29 11:28:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.