Bug 129773 - kernel 2.6.7-1.517smp panic during boot
kernel 2.6.7-1.517smp panic during boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 129750 129790 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-08-12 12:23 EDT by Clyde E. Kunkel
Modified: 2015-01-04 17:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-28 03:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2004-08-12 12:23:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
during boot of new kernel 2.6.7-1.517smp kernel panic occurs.  
Partial msgs follow:

Creating block devices
Creating root devices
Mounting root file system
Mount: error 6 mounting exts
Switching to new root
Switchroot: mount failed: 22
Kernel panic:  Attempted to kill init!

Same problem when trying with non-smp version.  Booting with .515smp 
is fine.  No entries that I can find in logs.

Grub.conf entry:

root (hd0,0)
kernel /vmlinuz-2.6.7-1.517smp ro root=LABEL=/1 psmouse.proto=imps
initrd /initrd-2.6.7-1.517smp.img


Version-Release number of selected component (if applicable):
2.6.7-1.517smp

How reproducible:
Always

Steps to Reproduce:
1.boot computer using kernel 2.6.7-1.517smp
2.
3.
    

Actual Results:  kernel panic after problem mounting root file system

Expected Results:  normal boot

Additional info:
Comment 1 Jeremy Katz 2004-08-12 14:26:25 EDT
mkinitrd 4.0.5 at http://people.redhat.com/~katzj/mkinitrd/ should fix
this (you'll need to rebuild your initrd)
Comment 2 Jeremy Katz 2004-08-12 14:27:27 EDT
*** Bug 129750 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-08-12 14:29:45 EDT
*** Bug 129790 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Reed 2004-08-12 14:51:27 EDT
Works for me, thanks.

rpm -Uvh mkinitrd-4.0.5-1.i386.rpm
mkinitrd -f /boot/initrd-2.6.7-1.517.img 2.6.7-1.517
reboot
Comment 5 Clyde E. Kunkel 2004-08-12 16:47:49 EDT
Works for me also.  Many thanks. 
Comment 6 Michael Wiktowy 2004-08-12 20:01:55 EDT
This solution works for me with the non-smp kernel also. Much appreciated.

Thanks also for the steps plainly laid out in comment 4 ... saved me
some man-ning to get the command format right.
Comment 7 Hannes Kuehnemund 2004-10-13 10:08:13 EDT
had the same problem when updating FC1 to FC3-test3 yesterday.

reissuing mkinitrd resolved the problem, probably problem in the
installer?
Comment 8 Nils Philippsen 2004-10-13 10:37:43 EDT
I'm reopening this one, as it seems that somehow the old mkinitrd got
run instead of the new one. I guess it may have went this way:

- Update from FC1 with rather ancient mkinitrd
- anaconda installs the kernel(s) before mkinitrd, because it can't
know it any better (kernel requires 3.5.5, FC1 has 3.5.14)
- initrds are bust because they can't work in the new environment

To fix this, I would have the kernel require current mkinitrd. Or
re-run mkinitrd after installing pkgs in anaconda, but this is kind of
lame.
Comment 9 Bill Nottingham 2004-10-20 01:08:33 EDT
kernel-2.6.9-1.639 prereqs a fairly recent mkinitrd.
Comment 10 Dave Jones 2004-11-27 17:34:18 EST
mass update for old bugs:

Is this still a problem in the 2.6.9 based kernel update ?
Comment 11 Clyde E. Kunkel 2004-11-27 20:24:57 EST
Not for me.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.