Bug 1297750 - volume info xml does not show arbiter details
volume info xml does not show arbiter details
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks: 1300174
  Show dependency treegraph
 
Reported: 2016-01-12 06:38 EST by Ravishankar N
Modified: 2016-06-16 09:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1300174 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2016-01-12 06:38:47 EST
Description of problem:
The arbiter count and the indication as to which brick(s) are the arbiters does not appear in `gluster vol info VOLNAME --xml`
Comment 1 Vijay Bellur 2016-01-12 11:11:11 EST
REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2016-01-13 05:01:41 EST
REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2016-01-18 01:56:22 EST
REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Vijay Bellur 2016-01-18 03:52:23 EST
REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 5 Vijay Bellur 2016-01-18 23:34:54 EST
REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Vijay Bellur 2016-01-20 01:31:40 EST
COMMIT: http://review.gluster.org/13229 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 67b7752eccd8eae6a91f3bc3ff55d65dcf858dc7
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jan 18 12:19:35 2016 +0530

    cli: Add arbiter details to volinfo xml output
    
    The following are added:
    1. "<arbiterCount>1</arbiterCount>" and
    "<coldarbiterCount>1</coldarbiterCount>"
    
    2. "<isArbiter>0</isArbiter>" on the brick info, like so:
    <brick
    uuid="cafa8612-d7d4-4007-beea-72ae7477f3bb">127.0.0.2:/home/ravi/bricks/brick1
    <name>127.0.0.2:/home/ravi/bricks/brick1</name>
    <hostUuid>cafa8612-d7d4-4007-beea-72ae7477f3bb</hostUuid>
    <isArbiter>0</isArbiter>
    </brick>
    
    Also fix a bug in gluster vol info where the abiter brick was shown the
    wrong brick of the cold tier after performing a tier-attach.
    
    Change-Id: Id978325d02b04f1a08856427827320e169169810
    BUG: 1297750
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13229
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:54:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.