Bug 1300174 - volume info xml does not show arbiter details
Summary: volume info xml does not show arbiter details
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 3.7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1297750
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-20 06:52 UTC by Ravishankar N
Modified: 2017-12-01 04:45 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1297750
Environment:
Last Closed: 2016-02-19 04:55:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
content of /var/lib/glusterd/vols/vmstore (2.44 KB, application/x-gzip)
2017-11-30 22:06 UTC, Rosario Esposito
no flags Details

Description Ravishankar N 2016-01-20 06:52:40 UTC
+++ This bug was initially created as a clone of Bug #1297750 +++

Description of problem:
The arbiter count and the indication as to which brick(s) are the arbiters does not appear in `gluster vol info VOLNAME --xml`

--- Additional comment from Vijay Bellur on 2016-01-12 11:11:11 EST ---

REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 05:01:41 EST ---

REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 01:56:22 EST ---

REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 03:52:23 EST ---

REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 23:34:54 EST ---

REVIEW: http://review.gluster.org/13229 (cli: Add arbiter details to volinfo xml output) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-20 01:31:40 EST ---

COMMIT: http://review.gluster.org/13229 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 67b7752eccd8eae6a91f3bc3ff55d65dcf858dc7
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jan 18 12:19:35 2016 +0530

    cli: Add arbiter details to volinfo xml output
    
    The following are added:
    1. "<arbiterCount>1</arbiterCount>" and
    "<coldarbiterCount>1</coldarbiterCount>"
    
    2. "<isArbiter>0</isArbiter>" on the brick info, like so:
    <brick
    uuid="cafa8612-d7d4-4007-beea-72ae7477f3bb">127.0.0.2:/home/ravi/bricks/brick1
    <name>127.0.0.2:/home/ravi/bricks/brick1</name>
    <hostUuid>cafa8612-d7d4-4007-beea-72ae7477f3bb</hostUuid>
    <isArbiter>0</isArbiter>
    </brick>
    
    Also fix a bug in gluster vol info where the abiter brick was shown the
    wrong brick of the cold tier after performing a tier-attach.
    
    Change-Id: Id978325d02b04f1a08856427827320e169169810
    BUG: 1297750
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13229
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 1 Vijay Bellur 2016-01-20 06:54:04 UTC
REVIEW: http://review.gluster.org/13263 (cli: Add arbiter details to volinfo xml output) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Vijay Bellur 2016-01-20 07:03:35 UTC
REVIEW: http://review.gluster.org/13263 (cli: Add arbiter details to volinfo xml output) posted (#2) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 3 Vijay Bellur 2016-01-20 07:12:15 UTC
REVIEW: http://review.gluster.org/13263 (cli: Add arbiter details to volinfo xml output) posted (#3) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 4 Vijay Bellur 2016-01-22 05:28:18 UTC
COMMIT: http://review.gluster.org/13263 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit aabbb0a1c1f65b34d05ce5e2a49ecc5c1c5e738f
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jan 18 12:19:35 2016 +0530

    cli: Add arbiter details to volinfo xml output
    
    Backport of  http://review.gluster.org/13229
    
    The followig are added:
    1. "<arbiterCount>1</arbiterCount>" and
    "<coldarbiterCount>1</coldarbiterCount>"
    
    2. "<isArbiter>0</isArbiter>" on the brick info, like so:
    <brick
    uuid="cafa8612-d7d4-4007-beea-72ae7477f3bb">127.0.0.2:/home/ravi/bricks/brick1
    <name>127.0.0.2:/home/ravi/bricks/brick1</name>
    <hostUuid>cafa8612-d7d4-4007-beea-72ae7477f3bb</hostUuid>
    <isArbiter>0</isArbiter>
    </brick>
    
    Also fix a bug in gluster vol info where the abiter brick was shown the
    wrong brick of the cold tier after performing a tier-attach.
    
    Change-Id: Id978325d02b04f1a08856427827320e169169810
    BUG: 1300174
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13263
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anuradha Talur <atalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Ravishankar N 2016-02-19 04:55:23 UTC
v3.7.7 contains a fix

Comment 6 Kaushal 2016-04-19 07:52:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Rosario Esposito 2017-11-30 22:05:01 UTC
Hi,
I have the same problem on 3.12.3.

I created a replicated volume with 3 bricks (third is the arbiter).
Everything seems to work fine but "gluster volume info" is not showing the arbiter:

Volume Name: vmstore
Type: Replicate
Volume ID: b15f85e9-259b-4e7b-9b0d-453f12094a3d
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Bricks:
Brick1: cloud05-gl.na.infn.it:/vmbrick/data
Brick2: cloud06-gl.na.infn.it:/vmbrick/data
Brick3: cloud04-gl.na.infn.it:/vmbrick/data

Can you please have a look ?

Comment 8 Rosario Esposito 2017-11-30 22:06:29 UTC
Created attachment 1361317 [details]
content of /var/lib/glusterd/vols/vmstore

# gluster --version
glusterfs 3.12.3
Repository revision: git://git.gluster.org/glusterfs.git
Copyright (c) 2006-2016 Red Hat, Inc. <https://www.gluster.org/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.

Comment 9 Ravishankar N 2017-12-01 04:45:41 UTC
Rosario, let us continue the discussion in the github issue you raised at https://github.com/gluster/glusterfs/issues/367


Note You need to log in before you can comment on or make changes to this bug.