Bug 1297797 - Ship a separate cockpit-docker subpackage on RHEL
Ship a separate cockpit-docker subpackage on RHEL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dominik Perpeet
Jan Ščotka
Yoana Ruseva
: Extras
Depends On:
Blocks: ovirt-node-ng 1292918
  Show dependency treegraph
 
Reported: 2016-01-12 08:41 EST by Stef Walter
Modified: 2016-08-08 11:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: cockpit-0.93-1.el7
Doc Type: Release Note
Doc Text:
A separate cockpit-docker subpackage is now shipped Previously, the Cockpit docker support was shipped with the _cockpit-shell_ subpackage. Now, the _cockpit-docker_ subpackage is available to be installed separately on Red Hat Enterprise Linux and is included in the _ostree_ available for Red Hat Enterprise Linux Atomic Host.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 11:20:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2016-01-12 08:41:32 EST
Ship a separate cockpit-docker subpackage on RHEL.

On Fedora we ship Cockpit docker support in a separate subpackage, so that it can be optionally installed if desired. Up until now, on RHEL we've been folding it into the cockpit-shell subpackage instead. 

Going forward, due to the needs of RHEV-H, we need to split out cockpit-docker on RHEL. This means including it as a line item in RHEL Atomic Tree as well.
Comment 9 errata-xmlrpc 2016-02-16 11:20:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0227.html
Comment 10 Fabian Deutsch 2016-08-08 11:17:42 EDT
Yes, we still see it:

[root@dhcp-10-16 ~]# rpm -q --whatrequires docker
cockpit-docker-0.114-2.el7.x86_64
[root@dhcp-10-16 ~]# rpm -q --whatrequires cockpit-docker
cockpit-0.114-2.el7.x86_64

Note You need to log in before you can comment on or make changes to this bug.