Bug 1297811 - The ipa -e skip_version_check=1 still issues incompatibility error when called against RHEL 6 server
The ipa -e skip_version_check=1 still issues incompatibility error when calle...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: ZStream
Depends On:
Blocks: 1298104
  Show dependency treegraph
 
Reported: 2016-01-12 09:19 EST by Jan Pazdziora
Modified: 2016-11-04 01:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: ipa-4.2.0-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298104 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2016-01-12 09:19:56 EST
Description of problem:

The change from bug 1211589 / ticket https://fedorahosted.org/freeipa/ticket/4768 introduced new option skip_version_check which is documented in man default.conf(5) as

    skip_version_check <boolean>

        Skip client vs. server API version checking. Can lead to errors/strange behavior when newer clients talk to older servers. Use with caution.

It works when used with RHEL 7.2 IPA client enrolled against (say) RHEL 7.1 server but does not work against RHEL 6 server.

Version-Release number of selected component (if applicable):

ipa-admintools-4.2.0-15.el7.x86_64

On server, ipa-server-3.0.0-47.el6.x86_64 is installed.

How reproducible:

Deterministic.

Steps to Reproduce:
1. ipa user-find
2. ipa -e skip_version_check=1 user-find

Actual results:

# ipa user-find
ipa: ERROR: 2.156 client incompatible with 2.49 server at u'https://ipa.example.com/ipa/xml'
# ipa -e skip_version_check=1 user-find
ipa: ERROR: 2.51 client incompatible with 2.49 server at u'https://ipa.example.com/ipa/xml'

Expected results:

# ipa user-find
ipa: ERROR: 2.156 client incompatible with 2.49 server at u'https://ipa.example.com/ipa/xml'
# ipa -e skip_version_check=1 user-find

users listed, no error

Additional info:
Comment 1 Jan Pazdziora 2016-01-12 09:24:28 EST
With ipa-server-3.0.0-25.el6.x86_64 from RHEL 6.4 which reports API version 2.46, and when forcing the client version to that value,

   # ipa user-find 

still fails with

   ipa: ERROR: Unknown option: no_members

with no incompatibility error.

With ipa-server-3.0.0-42.el6.x86_64 and ipa-server-3.0.0-47.el6.x86_64, the incompatibility error happens.
Comment 2 Jan Cholasta 2016-01-12 09:36:44 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5601
Comment 5 Martin Kosek 2016-01-12 10:57:55 EST
Blocking integration of other product, setting high sev/prio.
Comment 9 Sudhir Menon 2016-08-05 04:39:22 EDT
Client incompatible error is not displayed.
Verified using RHEL7.3 client and RHEL6.8 Server

ipa-server-3.0.0-50.el6.1.x86_64
ipa-client-4.4.0-4.el7.x86_64

[root@client ~]# ipa user-find
--------------
1 user matched
--------------
  User login: admin
  Last name: Administrator
  Home directory: /home/admin
  Login shell: /bin/bash
  UID: 639000000
  GID: 639000000
  Account disabled: False
  Password: True
  Kerberos keys available: True
----------------------------
Number of entries returned 1
----------------------------
[root@client ~]# ipa -e skip_version_check=1 user-find
--------------
1 user matched
--------------
  User login: admin
  Last name: Administrator
  Home directory: /home/admin
  Login shell: /bin/bash
  UID: 639000000
  GID: 639000000
  Account disabled: False
  Password: True
  Kerberos keys available: True
----------------------------
Number of entries returned 1
----------------------------
Comment 11 errata-xmlrpc 2016-11-04 01:48:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.