This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298104 - The ipa -e skip_version_check=1 still issues incompatibility error when called against RHEL 6 server
The ipa -e skip_version_check=1 still issues incompatibility error when calle...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: ZStream
Depends On: 1297811
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 04:04 EST by Jan Kurik
Modified: 2016-02-16 05:59 EST (History)
10 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.4
Doc Type: Bug Fix
Doc Text:
If the "skip_version_check" option was enabled, the IdM client identified itself as a client of IdM API version 2.51 to the IdM server. When the IdM API version of the IdM server was earlier than 2.51, the "skip_version_check" option on the client had no effect. Consequently, all API calls failed with an incompatible version error. With this update, if the "skip_version_check" option is enabled, the IdM client is identified as a client of IdM API version 2.0 to the IdM server, and the API calls no longer fail in the described scenario.
Story Points: ---
Clone Of: 1297811
Environment:
Last Closed: 2016-02-16 05:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-13 04:04:34 EST
This bug has been copied from bug #1297811 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Sudhir Menon 2016-01-27 06:26:27 EST
Fix is seen. Verified using the below.

===IPA-Client RHEL-7.2.z===
[root@host3 ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)
     
[root@host3 ~]# rpm -qa | grep ipa-client
ipa-client-4.2.0-15.el7_2.5.x86_64
        
[root@host3 ~]# ipa user-find
ipa: ERROR: 2.156 client incompatible with 2.49 server at u'https://host1.ndehadrai.in/ipa/xml'
     
[root@host3 ~]# ipa -e skip_version_check=1 user-find
--------------
1 user matched
--------------
      User login: admin
      Last name: Administrator
      Home directory: /home/admin
      Login shell: /bin/bash
      UID: 1304800000
      GID: 1304800000
      Account disabled: False
      Password: True
      Kerberos keys available: True
----------------------------
    Number of entries returned 1
----------------------------

===IPA Server===     
[root@host1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)

[root@host1 ~]# rpm -qa | grep ipa-server
ipa-server-3.0.0-47.el6_7.1.x86_64
Comment 6 errata-xmlrpc 2016-02-16 05:59:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0211.html

Note You need to log in before you can comment on or make changes to this bug.