Bug 1297897 - RFE: "heal" commands output should have a fixed fields
RFE: "heal" commands output should have a fixed fields
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Pranith Kumar K
: FutureFeature
Depends On:
Blocks: 1315141
  Show dependency treegraph
 
Reported: 2016-01-12 12:47 EST by Pranith Kumar K
Modified: 2016-06-16 09:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1097555
: 1315141 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-12 12:49:58 EST
REVIEW: http://review.gluster.org/13231 (heal: Have fixed number of fields in heal info output) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-01-28 04:30:56 EST
REVIEW: http://review.gluster.org/13231 (heal: Have fixed number of fields in heal info output) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-01-28 06:29:28 EST
REVIEW: http://review.gluster.org/13231 (heal: Have fixed number of fields in heal info output) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-01-29 01:39:08 EST
REVIEW: http://review.gluster.org/13231 (heal: Have fixed number of fields in heal info output) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-02-02 05:25:18 EST
COMMIT: http://review.gluster.org/13231 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit ac3183a5012bfed26fa0aead7f359f5d5b00e23e
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Dec 21 17:55:49 2015 +0530

    heal: Have fixed number of fields in heal info output
    
    Sample output:
    ⚡ gluster v heal r2 info
    Brick localhost.localdomain:/home/gfs/r2_0
    /a
    /
    Status: Connected
    Number of entries: 2
    
    Brick localhost.localdomain:/home/gfs/r2_1
    Status: Transport endpoint is not connected
    Number of entries: -
    
    Brick localhost.localdomain:/home/gfs/r2_2
    Status: Connected
    Number of entries: 0
    
    Brick localhost.localdomain:/home/gfs/r2_3
    Status: Connected
    Number of entries: 0
    
    Partial failure will print:
    ...
    <gfid:3efb51cf-5fa5-4bed-817b-afd600e9449e>
    Status: Failed to process entries completely. (Transport endpoint is not connected)
    Number of entries: 372
    ...
    
    BUG: 1297897
    Change-Id: I79131cbf255acd98f11eedafb53246c465f6665d
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13231
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Sahina Bose <sabose@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Mike McCune 2016-03-28 19:18:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Niels de Vos 2016-06-16 09:54:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.