This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315141 - RFE: "heal" commands output should have a fixed fields
RFE: "heal" commands output should have a fixed fields
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Pranith Kumar K
: FutureFeature
Depends On: 1297897
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 22:14 EST by Pranith Kumar K
Modified: 2016-04-19 02:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1297897
Environment:
Last Closed: 2016-04-19 02:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-06 22:19:57 EST
REVIEW: http://review.gluster.org/13616 (heal: Have fixed number of fields in heal info output) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-18 02:44:55 EDT
COMMIT: http://review.gluster.org/13616 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0b4f733f5ef074a38dacd33b39e5371d467d0f25
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Dec 21 17:55:49 2015 +0530

    heal: Have fixed number of fields in heal info output
    
    Sample output:
    ⚡ gluster v heal r2 info
    Brick localhost.localdomain:/home/gfs/r2_0
    /a
    /
    Status: Connected
    Number of entries: 2
    
    Brick localhost.localdomain:/home/gfs/r2_1
    Status: Transport endpoint is not connected
    Number of entries: -
    
    Brick localhost.localdomain:/home/gfs/r2_2
    Status: Connected
    Number of entries: 0
    
    Brick localhost.localdomain:/home/gfs/r2_3
    Status: Connected
    Number of entries: 0
    
    Partial failure will print:
    ...
    <gfid:3efb51cf-5fa5-4bed-817b-afd600e9449e>
    Status: Failed to process entries completely. (Transport endpoint is not connected)
    Number of entries: 372
    ...
    
     >BUG: 1297897
     >Change-Id: I79131cbf255acd98f11eedafb53246c465f6665d
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13231
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
     >Reviewed-by: Sahina Bose <sabose@redhat.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    
    BUG: 1315141
    Change-Id: I98de851b86598bb9c98e6203f855b69b585e2271
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13616
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
Comment 3 Kaushal 2016-04-19 02:59:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.