Bug 12979 - Dependency loop failure during upgrade.
Summary: Dependency loop failure during upgrade.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 13006 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-24 04:22 UTC by Henri Schlereth
Modified: 2007-04-18 16:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-12 22:41:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henri Schlereth 2000-06-24 04:22:29 UTC
During a GUI upgrade from 6.2 --> beta2 it first comes up with
(this is a non-custom upgrade). The original machine is a 6.2 server
machine.

Failed dependencies
package       requires
initscripts   modutils
Mesa          XFree86
kudzu         modutils

So I hit next and get a huge dependency list against glibc.
cpp,samba-common,at,inn,ctags,wu-ftpd,tcsh,shadow-utils,XFree86
util-linux,mod_perl,samba,pmake,pam,ucd-snmp,ncurses,rpm,db2,db3
textutils,pwdb,tar,findutils,sh-utils,samba-client,ypbind,gnupg
LPRng,postgresql-server,hdparm,db3-utils,bash,sendmail,SysVinit
XFree86-libs,python,mutt,ncurses,bind,emacs-nox,pine,m4,perl
php,apache,xinetd,pidentd,fetchmail,make,fileutils,ypserv

Additionally I have vt3 console messages that state
mkbootdisk conflicts with to-be-installed package modutils, removing from
set, * removed and so on. Most of these were removed against 
glibc/glibc-devel

I hit next again and it loops back to

failed dependencies
initscripts --> modutils
kuduzu--> modutils.

And then back to the massive failure list. And loop.

Comment 1 Henri Schlereth 2000-06-24 15:57:54 UTC
This may be related to 12276/11987 w/o the disk space problem.

Comment 2 Henri Schlereth 2000-06-24 15:59:58 UTC
The aborted install (because of the loop) does wipe out the old rpm database
but left the new db files in place, I was able to proceed with a text
install which will be documented in a different bug.

Comment 3 Matt Wilson 2000-07-12 22:40:56 UTC
fixed in beta3

Comment 4 Matt Wilson 2000-07-12 22:41:10 UTC
*** Bug 13006 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.