Bug 13006 - glibc upgrade failed.
glibc upgrade failed.
Status: CLOSED DUPLICATE of bug 12979
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-24 19:21 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-28 23:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2000-06-24 19:21:15 EDT
Fresh install of Red Hat 6.2.  Applied all patches except for kernel and
wu-ftpd.

Beta2 upgrade in graphical mode.

After choosing the upgrade path, got to the point where the installer
reported an unresolved dependency on modutils by initscripts and kudzu.

Hit "Back" on that screen.

Hit "Forward".

This time, in addition to initscript and kudzu, the installer reports about
thirty packages with an unresolved dependency on glibc.

Chose default option to proceed.

Installer completes eventually, without reporting any errors.

The resulting system fails to boot, with the following error:

init: /lib/libc.so.6 : version GLIBC_2.2 not found (required by init)
Comment 1 Sam Varshavchik 2000-06-24 20:31:39 EDT
Restarted install, went into a shell.

glibc 2.1.90 was definitely not installed.

Attempted to rpm -U glibc 2.1.90 manually.

First attempt:

/usr/bin/memprof conflicts with file from package memprof 0.3.0-5

Fair enough.  rpm -e memprof

rpm -U glibc again, worked, machine then rebooted fine.

Checked things around -- sure enough, the memprof 0.3.0-5 package on the beta2
CD conflicts with glibc 2.1.90 686 rpm.  This will be filed as a separate bug.

Comment 2 Sam Varshavchik 2000-06-24 20:40:20 EDT
I should also mention that I reran the installer two more times, once in text
once in graphical mode (before I manually reinstalled glibc).  In both cases
glibc still wasn't copied by the installer.
Comment 3 Daniel Powell 2000-06-28 23:02:04 EDT
I also had the same kind of problems. The dependancies failed for most of my 
packages and the installer looped between modutils and glibc being a problem. 
A look at tty3 told me of dependancy conflicts. 

This does not seem to be a single occurance

djpowell@flogeeks.org
Comment 4 Matt Wilson 2000-07-12 18:41:11 EDT

*** This bug has been marked as a duplicate of 12979 ***

Note You need to log in before you can comment on or make changes to this bug.