Bug 12980 - gdm fails to start, respawns repeatedly
gdm fails to start, respawns repeatedly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
: 13021 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-24 02:22 EDT by Brian Ryner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 00:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2000-06-24 02:22:18 EDT
After a clean installation of beta2, gdm failed to start.  The background 
image appeared, but at the point that the login dialog should have 
appeared, it died and respawned the X server.  It continued to do this 
over and over until I rebooted the system.  The log in /var/gdm/ indicated 
that the connection to the server was refused (I don't have the exact text 
onhand).
Comment 1 David Mason 2000-06-25 10:19:47 EDT
pbrown -  this is the problem I was telling you about where the 75DPI fonts are
not being installed. GDM is looking for helvetica and not finding it. We are
going to patch GDM to default down to other fonts but this is a problem with
those fonts not being installed moreso a GDM problem
Comment 2 David Mason 2000-06-25 15:43:19 EDT
*** Bug 13021 has been marked as a duplicate of this bug. ***
Comment 3 Arenas Belon, Carlo Marcelo 2000-06-26 22:28:00 EDT
getting the same problem here.., but XFree86-75dpi-fonts IS installed
and "xfs" IS running

gdm just restarts, while xdm works fine (didn't test kdm BTW)

on /var/gdm there is a core file of "gdmlogin" (signal 11)

the message on /var/gmd/0:Log tells :

could not open default font 'fixed'
Comment 4 Brian Ryner 2000-06-27 00:06:49 EDT
It seems that the XFree86-75dpi-fonts postinstall script fails to add it to the
xfs fontpath.  I inserted it in /etc/X11/fs/config like this:

catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/Type1,

gdm seems to work after doing this.
Comment 5 Bill Nottingham 2000-07-06 17:06:29 EDT
This was fixed in the 0.29+ XFree86 packages; the %post scripts
for the fonts were missing.

Note You need to log in before you can comment on or make changes to this bug.