Bug 1298100 - Broken 7.2.0 to 7.2.z upgrade - flawed version comparison
Broken 7.2.0 to 7.2.z upgrade - flawed version comparison
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: ZStream
Depends On: 1290142
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 04:02 EST by Jan Kurik
Modified: 2016-02-16 05:58 EST (History)
16 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.4
Doc Type: Bug Fix
Doc Text:
The version check during an IdM Server upgrade did not detect Red Hat Enterprise Linux version 7.2.z as a later one. Consequently, it was impossible to upgrade an IdM Server from version 7.2 to 7.2.z. This bug has been fixed, and the upgrade of an IdM Server from version 7.2 to 7.2.z is now successful.
Story Points: ---
Clone Of: 1290142
Environment:
Last Closed: 2016-02-16 05:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update process logs for ipa 7.2 > 7.2up2 (6.28 KB, text/plain)
2016-01-27 09:02 EST, Nikhil Dehadrai
no flags Details
update process logs for ipa 7.2up1 > 7.2up2 (4.85 KB, text/plain)
2016-01-27 09:02 EST, Nikhil Dehadrai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2085673 None None None 2016-01-13 04:02 EST

  None (edit)
Description Jan Kurik 2016-01-13 04:02:25 EST
This bug has been copied from bug #1290142 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Nikhil Dehadrai 2016-01-27 08:59:18 EST
IPA server 7.2: ipa-server-3.3.3-28.el7.x86_64
IPA server 7.2 update 1: ipa-server-4.2.0-15.el7_2.3.x86_64
IPA server 7.2 update 2: ipa-server-4.2.0-15.el7_2.5.x86_64

Verified the bug with following steps:
1. Verified that update of ipa server is successful from RHEL 7.2 => RHEL 7.2 update2.

2. Verified that update of ipa server is successful from RHEL 7.2 update1 => RHEL 7.2 update2. 

Thus on the basis of above observations, marking the status of bug to "VERIFIED".

Please refer the attachment for logs related to this upgrade process.
Comment 5 Nikhil Dehadrai 2016-01-27 09:02 EST
Created attachment 1118788 [details]
update process logs for ipa 7.2 > 7.2up2
Comment 6 Nikhil Dehadrai 2016-01-27 09:02 EST
Created attachment 1118789 [details]
update process logs for ipa 7.2up1 > 7.2up2
Comment 8 errata-xmlrpc 2016-02-16 05:58:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0211.html

Note You need to log in before you can comment on or make changes to this bug.