Bug 1298111 - Fix sparse-file-self-heal.t and remove from bad tests
Fix sparse-file-self-heal.t and remove from bad tests
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks: 1300210
  Show dependency treegraph
 
Reported: 2016-01-13 04:43 EST by Ravishankar N
Modified: 2016-06-16 09:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1300210 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2016-01-13 04:43:40 EST
Description of problem:

Psuedo Problem:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull

    The 'zeroedfile' disk usage comparision which is failing in this .t file
    fails so only on XFS. The test passes when the backend is on a s̶a̶n̶e̶r̶
    different filesystem like EXT4 or BTRFS. This is due to the speculative
    preallocation in XFS which can reserve different disk space on different
    XFS mounts for the same version and same file operation. See BZ 1277992
    for an example of XFS behaviour.

    Fix:
    Don't compare the disk usage of the file on the bricks of the replica:
    instead, check that the disk space consumed is atleast equal to the size
    of the file.

    Also remove sparse-file-self-heal.t from is_bad_test()
Comment 1 Vijay Bellur 2016-01-13 04:44:48 EST
REVIEW: http://review.gluster.org/13233 (tests: Fix sparse-file-self-heal.t) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2016-01-13 08:04:59 EST
REVIEW: http://review.gluster.org/13233 (tests: Fix sparse-file-self-heal.t) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2016-01-20 04:22:57 EST
COMMIT: http://review.gluster.org/13233 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6d430b85a39784f96b69368e1a9c8b4be4d0ddb1
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Jan 13 14:37:30 2016 +0530

    tests: Fix sparse-file-self-heal.t
    
    Psuedo Problem:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    The 'zeroedfile' disk usage comparision which is failing in this .t file
    fails so only on XFS. The test passes when the backend is on a s̶a̶n̶e̶r̶
    different filesystem like EXT4 or BTRFS. This is due to the speculative
    preallocation in XFS which can reserve different disk space on different
    XFS mounts for the same version and same file operation. See BZ 1277992
    for an example of XFS behaviour.
    
    Fix:
    Don't compare the disk usage of the file on the bricks of the replica:
    instead, check that the disk space consumed is atleast equal to the size
    of the file.
    
    Also remove sparse-file-self-heal.t from is_bad_test()
    
    Change-Id: If43f59549136ebf91f17ff9d958954b3587afe56
    BUG: 1298111
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13233
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Raghavendra Talur 2016-03-10 02:40:33 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 5 Niels de Vos 2016-06-16 09:54:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.