Bug 1300210 - Fix sparse-file-self-heal.t and remove from bad tests
Fix sparse-file-self-heal.t and remove from bad tests
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On: 1298111
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 04:30 EST by Ravishankar N
Modified: 2016-04-19 03:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298111
Environment:
Last Closed: 2016-02-18 23:56:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2016-01-20 04:30:46 EST
+++ This bug was initially created as a clone of Bug #1298111 +++

Description of problem:

Psuedo Problem:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull

    The 'zeroedfile' disk usage comparision which is failing in this .t file
    fails so only on XFS. The test passes when the backend is on a s̶a̶n̶e̶r̶
    different filesystem like EXT4 or BTRFS. This is due to the speculative
    preallocation in XFS which can reserve different disk space on different
    XFS mounts for the same version and same file operation. See BZ 1277992
    for an example of XFS behaviour.

    Fix:
    Don't compare the disk usage of the file on the bricks of the replica:
    instead, check that the disk space consumed is atleast equal to the size
    of the file.

    Also remove sparse-file-self-heal.t from is_bad_test()

--- Additional comment from Vijay Bellur on 2016-01-13 04:44:48 EST ---

REVIEW: http://review.gluster.org/13233 (tests: Fix sparse-file-self-heal.t) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:04:59 EST ---

REVIEW: http://review.gluster.org/13233 (tests: Fix sparse-file-self-heal.t) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-20 04:22:57 EST ---

COMMIT: http://review.gluster.org/13233 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6d430b85a39784f96b69368e1a9c8b4be4d0ddb1
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Jan 13 14:37:30 2016 +0530

    tests: Fix sparse-file-self-heal.t
    
    Psuedo Problem:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    The 'zeroedfile' disk usage comparision which is failing in this .t file
    fails so only on XFS. The test passes when the backend is on a s̶a̶n̶e̶r̶
    different filesystem like EXT4 or BTRFS. This is due to the speculative
    preallocation in XFS which can reserve different disk space on different
    XFS mounts for the same version and same file operation. See BZ 1277992
    for an example of XFS behaviour.
    
    Fix:
    Don't compare the disk usage of the file on the bricks of the replica:
    instead, check that the disk space consumed is atleast equal to the size
    of the file.
    
    Also remove sparse-file-self-heal.t from is_bad_test()
    
    Change-Id: If43f59549136ebf91f17ff9d958954b3587afe56
    BUG: 1298111
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13233
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Vijay Bellur 2016-01-20 04:31:13 EST
REVIEW: http://review.gluster.org/13265 (tests: Fix sparse-file-self-heal.t) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2016-01-21 04:51:07 EST
REVIEW: http://review.gluster.org/13265 (tests: Fix sparse-file-self-heal.t) posted (#2) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2016-01-25 06:36:46 EST
COMMIT: http://review.gluster.org/13265 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fa6545a323df920768dd25989537e6a350c10432
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Jan 20 14:58:48 2016 +0530

    tests: Fix sparse-file-self-heal.t
    
    Backport of http://review.gluster.org/13233
    Psuedo Problem:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    The 'zeroedfile' disk usage comparision which is failing in this .t file
    fails so only on XFS. The test passes when the backend is on a s̶a̶n̶e̶r̶
    different filesystem like EXT4 or BTRFS. This is due to the speculative
    preallocation in XFS which can reserve different disk space on different
    XFS mounts for the same version and same file operation. See BZ 1277992
    for an example of XFS behaviour.
    
    Fix:
    Don't compare the disk usage of the file on the bricks of the replica:
    instead, check that the disk space consumed is atleast equal to the size
    of the file.
    
    Also remove sparse-file-self-heal.t from is_bad_test()
    
    Change-Id: If43f59549136ebf91f17ff9d958954b3587afe56
    BUG: 1300210
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13265
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.