Bug 1298309 - kernel 4.3.3-300 broken video on i915
kernel 4.3.3-300 broken video on i915
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
23
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 13:03 EST by Corinna Vinschen
Modified: 2016-01-31 17:36 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:24:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output showing fcrash in i915 driver (3.83 KB, text/plain)
2016-01-13 13:03 EST, Corinna Vinschen
no flags Details
dmesg log on Acer Aspire One ZG5 with kernel-PAE-4.3.3-301.fc23.i686 (71.64 KB, text/plain)
2016-01-21 21:02 EST, Alex Villacís Lasso
no flags Details
dmesg log on Acer Aspire One ZG5 with kernel-PAE-4.3.3-303.fc23.i686 (69.62 KB, text/plain)
2016-01-23 11:02 EST, Alex Villacís Lasso
no flags Details
dmesg kernel.4.2.8-300.fc23.i686+PAE with no backtrace (18.92 KB, application/x-gzip)
2016-01-23 14:50 EST, mm19827
no flags Details
dmesg kernel.4.3.3-303.fc23.i686+PAE with multiple drm backtraces (23.67 KB, application/x-gzip)
2016-01-23 14:51 EST, mm19827
no flags Details

  None (edit)
Description Corinna Vinschen 2016-01-13 13:03:15 EST
Created attachment 1114481 [details]
dmesg output showing fcrash in i915 driver

Description of problem:

  Upgrading an MSI Wind U100 clone from kernel 4.2.8-300 to 4.3.3-300
  breaks video output.  I attached the dmesg output which contains a
  kernel stackdump.

  After searching for this effect on the net I found this related
  issue on freedesktop.org:

    https://bugs.freedesktop.org/show_bug.cgi?id=92655

  and a matching patch

    https://bugs.freedesktop.org/attachment.cgi?id=119541

  Is it possible that this fix is missing in 4.3.3?

Version-Release number of selected component (if applicable):

  kernel-4.3.3-300.fc23.i686

How reproducible:

  Install aforementioned kernel on a MSI Wind or clone thereof with F23
  Reboot

Actual results:

  Garbeled video output

Expected results:

  Working video
Comment 1 Josh Boyer 2016-01-13 13:35:22 EST
(In reply to Corinna Vinschen from comment #0)
> Created attachment 1114481 [details]
> dmesg output showing fcrash in i915 driver
> 
> Description of problem:
> 
>   Upgrading an MSI Wind U100 clone from kernel 4.2.8-300 to 4.3.3-300
>   breaks video output.  I attached the dmesg output which contains a
>   kernel stackdump.
> 
>   After searching for this effect on the net I found this related
>   issue on freedesktop.org:
> 
>     https://bugs.freedesktop.org/show_bug.cgi?id=92655
> 
>   and a matching patch
> 
>     https://bugs.freedesktop.org/attachment.cgi?id=119541
> 
>   Is it possible that this fix is missing in 4.3.3?

Yes.  There are many patches marked for stable that are not in a stable release because the upstream maintainer is very behind.  This happens to be one of them.  It was only added into 4.4-rc6.

Please test this scratch build when it completes and let us know if it helps:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12537049
Comment 2 Corinna Vinschen 2016-01-14 04:08:51 EST
Hi Josh,

the test kernel you provided works as desired in terms of the
video problem on i915.


Thanks a lot,
Corinna
Comment 3 Alex Villacís Lasso 2016-01-14 10:44:27 EST
Also occurs on an Acer Aspire One ZG5. In my case the screen corruption affects the plymouth splash screen and leaves a black rectangle with random garbage filling 3/4 of the screen horizontally.
Comment 4 Josh Boyer 2016-01-14 19:41:50 EST
Thanks for testing!
Comment 5 Fedora Update System 2016-01-15 14:24:56 EST
kernel-4.3.3-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a
Comment 6 Fedora Update System 2016-01-17 09:22:53 EST
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a
Comment 7 Fedora Update System 2016-01-19 07:54:18 EST
kernel-4.3.3-302.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-db9fedd7c4
Comment 8 mm19827 2016-01-19 15:39:02 EST
Had the same problem on a Dell Latitude D620 with i945GM
With kernel-4.3.3-301.fc23 no garbage on screen, but the GNOME desktop is _very_ slow (not really usable), top shows gnome-shell consuming 100% CPU.

KDE and Xfce run fine.
Same with With kernel-4.3.3-302.fc23
possibly the same as reported in Bug 1299933
Comment 9 Fedora Update System 2016-01-20 16:51:47 EST
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Alex Villacís Lasso 2016-01-21 21:02 EST
Created attachment 1117072 [details]
dmesg log on Acer Aspire One ZG5 with kernel-PAE-4.3.3-301.fc23.i686

The bug is only partially solved for me. I don't get the screen corruption anymore but backtraces still appear in the kernel log.
Comment 11 Fedora Update System 2016-01-21 23:58:20 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be
Comment 12 Alex Villacís Lasso 2016-01-23 11:02 EST
Created attachment 1117466 [details]
dmesg log on Acer Aspire One ZG5 with kernel-PAE-4.3.3-303.fc23.i686

Still seeing backtraces with kernel from updates-testing, dmesg attached.
Comment 13 mm19827 2016-01-23 14:50 EST
Created attachment 1117471 [details]
dmesg kernel.4.2.8-300.fc23.i686+PAE with no backtrace
Comment 14 mm19827 2016-01-23 14:51 EST
Created attachment 1117472 [details]
dmesg kernel.4.3.3-303.fc23.i686+PAE with multiple drm backtraces

Still having bad behaviour from the GNOME desktop with kernel-PAE-4.3.3-303.fc23.i686
Just displaying the Activities menu takes 10 secs.

A number of drm backtraces are seen in the kernel log, which has no backtraces with kernel 4.2.8.
FWIW, note that my CPU does not support PAT - switch from MTRR to PAT has been a major change for kernel 4.3

Despite the backtraces, xfce and KDE behave properly.

dmesg attached for both 4.3.3.303 and 4.2.8
Comment 15 Fedora Update System 2016-01-26 13:22:43 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Richard Henwood 2016-01-31 17:36:54 EST
One data point:

I am using a Compaq Presario v6000, i686. Had very slow video with 4.3.3-30{1,2,3}.

I've booted into 4.4.0-1.vanilla.knurd.1.fc23.i686 from
https://fedoraproject.org/wiki/Kernel_Vanilla_Repositories
it's not great, but machine feels much more responsive and I consider it usable.

Note You need to log in before you can comment on or make changes to this bug.