Bug 1299933 - i915 freezes after GNOME session launch on 4.3.x kernels
i915 freezes after GNOME session launch on 4.3.x kernels
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 10:07 EST by steven.merrill
Modified: 2016-01-20 00:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 00:19:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel oops log from the system journal. (5.05 KB, text/plain)
2016-01-19 10:07 EST, steven.merrill
no flags Details
dmesg log gnome-shell 100% CPU (23.86 KB, application/x-gzip)
2016-01-19 16:46 EST, mm19827
no flags Details
dmesg from kernel 4.3.3-302 after starting a GNOME Wayland session (74.65 KB, text/plain)
2016-01-19 18:25 EST, steven.merrill
no flags Details

  None (edit)
Description steven.merrill 2016-01-19 10:07:11 EST
Created attachment 1116201 [details]
Kernel oops log from the system journal.

Description of problem:

I have a Dell Inspiron 7548 running Fedora 23. This laptop has AMD and Intel graphics and I am using the free radeon drivers.

All Fedora 4.3.x kernel releases (including 4.3.3-302 just released to Bodhi) freeze up after I authenticate in GDM. Sometimes it freezes on the gray GDM background and sometimes I can see my GNOME background and a notification icon on the top.

Launching a GNOME Wayland session works, although Wayland is somewhat buggy.

I am attaching the kernel crash logs from the system journal. I'd be happy to help track this down however I can - I'm currently keeping the 4.2.8 kernel around since it's the last one I can use with non-Wayland GNOME sessions.

Version-Release number of selected component (if applicable):

kernel-4.3.3-302.fc23
kernel-4.3.3-301.fc23
kernel-4.3.3-300.fc23

Steps to Reproduce:
1. Authenticate to GDM with "GNOME Session" selected.
2. The screen freezes.
Comment 1 Josh Boyer 2016-01-19 10:12:52 EST
Can you attach the output of dmesg from a fresh boot if that is possible?  The attachment here is somewhat helpful but it is not the first issue that occurred.
Comment 2 steven.merrill 2016-01-19 14:54:13 EST
Sure. Just to clarify, would you like the dmesg output from a successful boot into 4.2.8 where I start GNOME, or the dmesg output from a boot into 4.3.3-302 where I switch to a a different TTY and dump it (and/or start a GNOME Wayland session?)
Comment 3 Josh Boyer 2016-01-19 15:15:51 EST
The latter please.  Or both if it isn't too much trouble, but 4.2.8 likely isn't going to tell us much.
Comment 4 mm19827 2016-01-19 15:46:58 EST
Having probably the same problem on a dual-core Dell Latitude D620 with i945GM
After upgrade to kernel-4.3.3-300.fc23, display broken (Bug 1298309)
With kernel-4.3.3-301.fc23 no garbage on screen, but the GNOME desktop is _very_ slow (not really usable), top shows gnome-shell consuming 100% CPU.
KDE and Xfce run fine.
Same with kernel-4.3.3-302.fc23
KDM login screen also works fine (I do not use GDM)
4.2.8 works OK with GNOME, KDE, xfce
Comment 5 mm19827 2016-01-19 16:46 EST
Created attachment 1116397 [details]
dmesg log gnome-shell 100% CPU
Comment 6 Josh Boyer 2016-01-19 17:54:23 EST
(In reply to mm19827 from comment #4)
> Having probably the same problem on a dual-core Dell Latitude D620 with
> i945GM
> After upgrade to kernel-4.3.3-300.fc23, display broken (Bug 1298309)
> With kernel-4.3.3-301.fc23 no garbage on screen, but the GNOME desktop is
> _very_ slow (not really usable), top shows gnome-shell consuming 100% CPU.
> KDE and Xfce run fine.
> Same with kernel-4.3.3-302.fc23
> KDM login screen also works fine (I do not use GDM)
> 4.2.8 works OK with GNOME, KDE, xfce

Your hardware and bug do not appear to be at all similar to the original reporters.  Please file your own bug against xorg-x11-drv-intel.
Comment 7 steven.merrill 2016-01-19 18:25 EST
Created attachment 1116412 [details]
dmesg from kernel 4.3.3-302 after starting a GNOME Wayland session
Comment 8 steven.merrill 2016-01-19 18:31:26 EST
Josh,

Thanks for offering to help. I've attached dmesg from a boot into 4.3.3-302. I was able to launch a GNOME Wayland session and dump that. I then switched back into a regular GNOME session and got the freeze but the kernel crash logs for this time do not appear to be in my system journal.

I'll also note that both kernels are started using the 'i915.enable_ips=0' option because it fixes some strange display issues for me, and I have also added 'omit_drivers+=" hid_multitouch "' into a file in /etc/dracut.conf.d because without doing that I would get kernel panics before reaching GDM approximately 30-50% of the time.

Please let me know what else I can do to help test this out.
Comment 9 Josh Boyer 2016-01-19 20:23:18 EST
[    1.178272] Setting dangerous option enable_rc6 - tainting kernel
[    1.178274] Setting dangerous option enable_fbc - tainting kernel
[    1.178276] i915: unknown parameter 'lvds_downclock' ignored
[    1.178277] Setting dangerous option semaphores - tainting kernel

I don't see these options on the kernel cmdline, but something is clearly setting them.  What happens if you remove the entries in whatever file is doing that?
Comment 10 steven.merrill 2016-01-20 00:19:09 EST
Josh,

That did it.

I had made an /etc/modprobe.d/i915.conf file that had those 4 options in there. After removing the file and re-running dracut from GNOME Wayland, I'm happy to report that I'm booted into GNOME on 4.3.3-302. I'll run this tomorrow during the work day and if everything's good, karma the kernel update at the end of the day.

Thanks again for the help!

Note You need to log in before you can comment on or make changes to this bug.