Bug 129833 - service iiim start/restart/condrestart never completes
service iiim start/restart/condrestart never completes
Status: CLOSED DUPLICATE of bug 129785
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Yu Shao
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-12 23:48 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-08-12 23:48:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
# service iiim start
Starting IIIMF input server:
[hangs forever, even while booting up]

# ps auxww | grep htt
root      7150  0.0  0.1  4332  636 pts/9    S+   00:45   0:00 initlog
-q -c su -s /bin/bash - htt -c "/usr/sbin/htt"
root      7151  0.0  0.2  5008 1064 pts/9    S+   00:45   0:00 su -s
/bin/bash - htt -c /usr/sbin/htt
htt       7152  0.0  0.0  2844  312 pts/9    S    00:45   0:00
/usr/sbin/htt
htt       7174  0.0  0.5  8112 2752 pts/9    S    00:45   0:00
htt_server -nodaemon

What's with the `-nodaemon' option?!?

Version-Release number of selected component (if applicable):
iiimf-server-11.4-69.svn1856

How reproducible:
Always

Steps to Reproduce:
1.up2date FC3test1 to 2004-08-12's rawhide (had to remove some
iiimf-*-devel and iiimf-le-xcin to complete successfully)

Actual Results:  up2date hangs because the iiim condrestart won't
complete.  Killing it, up2date fails to complete.  After recovery and
reinstallation of all affected packages without htt running, rebooting
won't help because of the problem described above.  Ugh.

Expected Results:  start should complete eventually.

Additional info:
Comment 1 Yu Shao 2004-08-13 00:05:50 EDT
11.4-70.svn1856 has been build, it should fix the problem. "-nodaemon"
just tells htt_server if it should fork mulutple instances for each
service request.
Comment 2 Akira TAGOH 2004-08-25 05:23:48 EDT

*** This bug has been marked as a duplicate of 129785 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.