Bug 129785 - startup scripts hang at "starting IIIMF input server"
startup scripts hang at "starting IIIMF input server"
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: im-sdk (Show other bugs)
4.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Akira TAGOH
David Lawrence
: i18n
: 129833 129976 (view as bug list)
Depends On:
Blocks: FC3Target IIIMF 130007
  Show dependency treegraph
 
Reported: 2004-08-12 13:30 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: 11.4-70.svn1856
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 01:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2004-08-12 13:30:46 EDT
Observed RHEL4 0812 ia64.  0811 didn't have this problem.

We hang here in the startup scripts:

Starting sm-client: [  OK  ]
Starting console mouse services: (no mouse is configured)
Starting IIIMF input server:
                                                                     
          

[root@altix2 ~]# ps -ef | grep start
root      3822  1554  0 13:08 ?        00:00:00 /bin/sh
/etc/rc3.d/S87iiim startroot     26113  9785  0 13:19 pts/0   
00:00:00 grep start

I'm not opposed to looking at this a bit more.
Comment 1 Red Hat Bugzilla 2004-08-12 13:32:59 EDT
[root@altix2 ~]# ps -ef | grep 3822
root      3822  1554  0 13:08 ?        00:00:00 /bin/sh
/etc/rc3.d/S87iiim startroot      3825  3822  6 13:08 ?       
00:00:52 initlog -q -c su -s /bin/bash - htt -c "/usr/sbin/htt"

Comment 2 Red Hat Bugzilla 2004-08-12 13:47:38 EDT
htt starts htt_server with -nodaemon.
 
ps shows htt_server keeps restarting.
 
/var/log/messages is full of errors.  Here is a sample.
 
Aug 12 13:08:49 altix2 su(pam_unix)[3826]: session opened for user htt
by (uid=0)
Aug 12 13:08:50 altix2 su: terminate called after throwing an instance
of '
Aug 12 13:08:50 altix2 su: if_GetIfInfo == num_args:6
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: init objects, objects:0
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: if_GetIfInfo()
Aug 12 13:08:50 altix2 su: std::logic_error'
Aug 12 13:08:50 altix2 su:   what():  basic_string::_S_construct NULL
not valid
Aug 12 13:08:50 altix2 su: terminate called after throwing an instance
of '
Aug 12 13:08:50 altix2 su: if_GetIfInfo == num_args:6
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: init objects, objects:0
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: if_GetIfInfo()
Aug 12 13:08:50 altix2 su: std::logic_error'
Aug 12 13:08:50 altix2 su:   what():  basic_string::_S_construct NULL
not valid
Aug 12 13:08:50 altix2 su: terminate called after throwing an instance
of '
Aug 12 13:08:50 altix2 su: if_GetIfInfo == num_args:6
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: init objects, objects:0
Aug 12 13:08:50 altix2 su:
Aug 12 13:08:50 altix2 su: if_GetIfInfo()
Aug 12 13:08:50 altix2 su: std::logic_error'
Aug 12 13:08:50 altix2 su:   what():  basic_string::_S_construct NULL
not valid
Aug 12 13:08:50 altix2 su: if_GetIfInfo == num_args:6
Comment 3 Red Hat Bugzilla 2004-08-12 13:54:38 EDT
re-assign to proper component.  -Erik
Comment 4 Red Hat Bugzilla 2004-08-12 13:55:20 EDT
re-assign to proper owner of this component -erik
Comment 5 Red Hat Bugzilla 2004-08-12 20:42:13 EDT
what version of iiimf-server are you using? also which locale(just
type "locale" under prompt)?
Comment 6 Red Hat Bugzilla 2004-08-12 22:16:03 EDT
Hi.  This is also happens on Fedora Core nightly build 0812.
This info is from the Fedora Core installed ia64 system....

[root@altix2 ~]# rpm -qi iiimf-server
Name        : iiimf-server                 Relocations: (not relocatable)
Version     : 11.4                              Vendor: Red Hat, Inc.
Release     : 69.svn1856                    Build Date: Wed 11 Aug
2004 09:24:43 AM EDT
Install Date: Thu 12 Aug 2004 04:04:20 PM EDT      Build Host:
bullwinkle.build.redhat.com
Group       : Applications/System           Source RPM:
im-sdk-11.4-69.svn1856.src.rpm
Size        : 1329227                          License: Distributable
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.openi18n.org/subgroups/im/IIIMF/
Summary     : IIIMF input method server
Description :
IIIMF server is a server module of Internet/Intranet Input Method
Framework.


[root@altix2 ~]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Comment 7 Red Hat Bugzilla 2004-08-13 00:08:02 EDT
11.4-70.svn1856 has been build, it should fix this problem.
Comment 8 Red Hat Bugzilla 2004-08-13 11:35:01 EDT
FYI Rawhide 0813 still has this problem.  So we'll need to 
re-test next week.  -Erik
Comment 9 Red Hat Bugzilla 2004-08-14 23:18:05 EDT
This problem still exists in rawhide nightly build 0814.
Comment 10 Red Hat Bugzilla 2004-08-16 11:44:29 EDT
This problem still exists in rawhide nightly 0816
Comment 11 Red Hat Bugzilla 2004-08-16 20:31:04 EDT
Looks like the problem appeared since version 1:11.4-69.svn1833, Jens,
Tagoh, can you reproduce it?
Comment 12 Red Hat Bugzilla 2004-08-16 20:44:14 EDT
*** Bug 129976 has been marked as a duplicate of this bug. ***
Comment 13 Red Hat Bugzilla 2004-08-16 20:51:39 EDT
Hi Erik, can you give me the full ouput of "htt_server -d" after you
bypass the startup?
Comment 14 Red Hat Bugzilla 2004-08-16 20:57:51 EDT
Hi there.

I logged in to the machine and sent the HUP signal to the processes
involved in stopping the init scripts.  The rest of the startup scripts
went by.  I logged in as root and ran this:


[root@altix2 ~]# htt_server -d
Turn on debug mode.
SetDefaultPermission(deny)
AccessControl(permit):127.0.0.1
AllowSystemUser(password)
LE(thaile) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=true
    langs=th_TH,
object for thaile
    object_type      = 131
    object id        = 32769
    object size      = 0
    rev. domain name = com.sun
    path             = ./locale/th_TH/aux.so
    scope            = thaile
    signature        =
    basepath         =
    encoding         =
LE(chinput) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=false
    langs=zh_CN,
object for chinput
    object_type      = 131
    object id        = 32771
    object size      = 0
    rev. domain name = com.redhat
    path             = ./locale/zh_CN/chinput/aux.so
    scope            = chinput
    signature        =
    basepath         =
    encoding         =
LE(cle) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=true
    langs=zh_CN,
object for cle
    object_type      = 131
    object id        = 32773
    object size      = 0
    rev. domain name = com.sun
    path             = ./locale/zh_CN/aux.so
    scope            = cle
    signature        =
    basepath         =
    encoding         =
LE(unitle) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=true
    langs=en, he, ar, ru_RU, el_GR, vi_VN, ti_ER, am_ET, bn_IN, gu_IN,
pa_IN, hi_IN, kn_IN, ml_IN, ta_IN, te_IN, UNICODE-HEX, UNICODE-OCTAL,
LE(CannaLE) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=true
    langs=ja,
if_GetIfInfo == num_args:6
                                                                     
          
init objects, objects:0
                                                                     
          
LE(kole) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=true
    langs=ko,
object for kole
    object_type      = 131
    object id        = 32777
    object size      = 0
    rev. domain name = com.sun
    path             = ./locale/ko_KR/aux.so
    scope            = kole
    signature        =
    basepath         =
    encoding         =
if_GetIfInfo()
        This method is invoked when htt_server retrieves
        if_method_t method table.
                                                                     
          
LE(hangul) is loading.
    Path=/usr/lib/im/leif/
    version=11.0
    locale=
    need_thread_lock=false
    langs=ko, ko_KR,
LE(xcin) is loading.
    Path=/usr/lib/im/leif/
    version=0.1
    locale=
    need_thread_lock=false
    langs=zh_TW,
object for xcin
    object_type      = 131
    object id        = 32780
    object size      = 0
    rev. domain name = com.redhat
    path             = ./locale/zh_TW/aux.so
    scope            = xcin
    signature        =
    basepath         =
    encoding         =
LE(newpy) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=false
    langs=zh_CN,
object for newpy
    object_type      = 133
    object id        = 32782
    object size      = 516
    rev. domain name = com.sun
    path             = /usr/lib/im/locale/zh_CN/newpy/newpy_obj.jar
    scope            = newpy
    signature        =
    basepath         =
    encoding         =
    jarfile class    = com.sun.iiim.sample.newpy.NewPYPanel
object for newpy
    object_type      = 131
    object id        = 32783
    object size      = 0
    rev. domain name = com.sun
    path             = ./locale/zh_CN/newpy/aux.so
    scope            = newpy
    signature        =
    basepath         =
    encoding         =
LE(xcin) is loading.
    Path=/usr/lib/im/leif/
    version=0.1
    locale=
    need_thread_lock=false
    langs=zh_TW,
object for xcin
    object_type      = 131
    object id        = 32785
    object size      = 0
    rev. domain name = com.redhat
    path             = ./locale/zh_TW/aux.so
    scope            = xcin
    signature        =
    basepath         =
    encoding         =
if_GetIfInfo()
LE(FreeWnnLE) is loading.
    Path=/usr/lib/im/leif/
    version=1.2
    locale=
    need_thread_lock=false
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
Aborted

Comment 16 Red Hat Bugzilla 2004-08-16 21:03:58 EDT
Ok, the problem seems with FreeWnnLE.
Comment 19 Red Hat Bugzilla 2004-08-17 00:26:57 EDT
I apologize to not getting fixed this soon. as Shao says, this problem
should be fixed in -70.svn1856. but that rebuilding was failed due to
Bug#129723. plus, I forgot to try to build it again after closing it.
Anyway it should be fixed in -70.svn1856 soon. please confirm on it.

Thanks,
Comment 20 Red Hat Bugzilla 2004-08-18 11:22:55 EDT
This is fixed in rawhide 0818.  I just did an 'everything' install 
and the server starts up fine and bootup continues normally. 
 
Jesse 
 
 
Comment 21 Red Hat Bugzilla 2004-08-19 01:49:06 EDT
Thanks, close this then.
Comment 22 Red Hat Bugzilla 2004-08-25 05:23:51 EDT
*** Bug 129833 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.