Bug 1298520 - tests : Modifying tests for crypt xlator
tests : Modifying tests for crypt xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
: Reopened, Triaged
Depends On:
Blocks: 1303033 1308806 1308807
  Show dependency treegraph
 
Reported: 2016-01-14 05:26 EST by Jiffin
Modified: 2017-01-05 14:04 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1303033 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2016-01-14 05:26:59 EST
Description of problem:
The test cases for crypt xlator is creating core for client processes due to absence of master key file.Before enabling it is required to create the same

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
log file for gluster nfs 
 [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down
Comment 1 Vijay Bellur 2016-01-14 05:28:25 EST
REVIEW: http://review.gluster.org/13240 (tests : Modifying crypt xlators unit tests) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-01-19 03:40:35 EST
REVIEW: http://review.gluster.org/13240 (tests: set master key before enabling crypt xlator) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Vijay Bellur 2016-01-19 08:00:46 EST
REVIEW: http://review.gluster.org/13240 (tests : Modifying crypt xlators unit tests) posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2016-01-24 07:35:04 EST
COMMIT: http://review.gluster.org/13240 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ca4d4a26a553bac9c627bc6e6d6c9fa1f9435297
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Thu Jan 14 15:07:47 2016 +0530

    tests : Modifying crypt xlators unit tests
    
    The "encryption.master-key" should be set before enabling crypt xlators.
    Otherwise glusterfs client process(like gluster-NFS) will crash due to the
    failure in intialising crypt xlator.
    
    You can see the following messages in client log file
    [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down
    
    Change-Id: I124deda505d128eacb15ca20fbdcd1593cb8eba3
    BUG: 1298520
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13240
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Niels de Vos 2016-01-24 07:36:33 EST
Please check if it is needed to backport this to 3.7 and 3.6 too. File bugs for the affected versions and send backports please.
Comment 6 Jiffin 2016-01-29 05:04:35 EST
Sorry for the delay, I will check whether backport is needed and do the same
Comment 7 Niels de Vos 2016-06-16 09:54:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.