Bug 1308806 - tests : Modifying tests for crypt xlator
tests : Modifying tests for crypt xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.6.8
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On: 1298520 1303033
Blocks: 1308807
  Show dependency treegraph
 
Reported: 2016-02-16 02:07 EST by Jiffin
Modified: 2016-03-04 10:57 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-glusterfs-3.6.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303033
: 1308807 (view as bug list)
Environment:
Last Closed: 2016-03-04 10:28:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2016-02-16 02:07:58 EST
+++ This bug was initially created as a clone of Bug #1303033 +++

+++ This bug was initially created as a clone of Bug #1298520 +++

Description of problem:
The test cases for crypt xlator is creating core for client processes due to absence of master key file.Before enabling it is required to create the same

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
log file for gluster nfs 
 [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down

--- Additional comment from Vijay Bellur on 2016-01-14 05:28:25 EST ---

REVIEW: http://review.gluster.org/13240 (tests : Modifying crypt xlators unit tests) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-19 03:40:35 EST ---

REVIEW: http://review.gluster.org/13240 (tests: set master key before enabling crypt xlator) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-19 08:00:46 EST ---

REVIEW: http://review.gluster.org/13240 (tests : Modifying crypt xlators unit tests) posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-24 07:35:04 EST ---

COMMIT: http://review.gluster.org/13240 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ca4d4a26a553bac9c627bc6e6d6c9fa1f9435297
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Thu Jan 14 15:07:47 2016 +0530

    tests : Modifying crypt xlators unit tests
    
    The "encryption.master-key" should be set before enabling crypt xlators.
    Otherwise glusterfs client process(like gluster-NFS) will crash due to the
    failure in intialising crypt xlator.
    
    You can see the following messages in client log file
    [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down
    
    Change-Id: I124deda505d128eacb15ca20fbdcd1593cb8eba3
    BUG: 1298520
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13240
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

--- Additional comment from Niels de Vos on 2016-01-24 07:36:33 EST ---

Please check if it is needed to backport this to 3.7 and 3.6 too. File bugs for the affected versions and send backports please.

--- Additional comment from Jiffin on 2016-01-29 05:04:35 EST ---

Sorry for the delay, I will check whether backport is needed and do the same

--- Additional comment from Vijay Bellur on 2016-01-29 06:37:22 EST ---

REVIEW: http://review.gluster.org/13320 (tests : Modifying crypt xlators unit tests) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-09 09:12:53 EST ---

COMMIT: http://review.gluster.org/13320 committed in release-3.7 by Jeff Darcy (jdarcy@redhat.com) 
------
commit 75b7fd344de28f9c79940722f9d9f9e5342ddcd8
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Thu Jan 14 15:07:47 2016 +0530

    tests : Modifying crypt xlators unit tests
    
    Backport of http://review.gluster.org/#/c/13240/
    
    The "encryption.master-key" should be set before enabling crypt xlators.
    Otherwise glusterfs client process(like gluster-NFS) will crash due to the
    failure in intialising crypt xlator.
    
    You can see the following messages in client log file
    [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down
    
    Upstream reference
    -------------------
    >Change-Id: I124deda505d128eacb15ca20fbdcd1593cb8eba3
    >BUG: 1298520
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/13240
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >(cherry picked from commit ca4d4a26a553bac9c627bc6e6d6c9fa1f9435297)
    
    Change-Id: I8073765b02cd4bebc202fbae5ef7558df25ea664
    BUG: 1303033
    Reviewed-on: http://review.gluster.org/13320
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Vijay Bellur 2016-02-16 02:08:29 EST
REVIEW: http://review.gluster.org/13453 (tests : Modifying crypt xlators unit tests) posted (#1) for review on release-3.6 by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-02-18 09:31:48 EST
COMMIT: http://review.gluster.org/13453 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit cc4f0697d705463f7907e8179a26bfd8d09745e3
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Thu Jan 14 15:07:47 2016 +0530

    tests : Modifying crypt xlators unit tests
    
    Backport of http://review.gluster.org/#/c/13240/
    
    The "encryption.master-key" should be set before enabling crypt xlators.
    Otherwise glusterfs client process(like gluster-NFS) will crash due to the
    failure in intialising crypt xlator.
    
    You can see the following messages in client log file
    [2016-01-14 08:13:15.740835] E [crypt.c:4298:master_set_master_vol_key]
    0-test1-crypt: FATAL: missing master key
    [2016-01-14 08:13:15.740859] E [MSGID: 101019]
    [xlator.c:429lator_init] 0-test1-crypt: Initialization of volume
    'test1-crypt' failed, review your volfile again
    [2016-01-14 08:13:15.740890] E [MSGID: 101066]
    [graph.c:324:glusterfs_graph_init] 0-test1-crypt: initializing
    translator failed
    [2016-01-14 08:13:15.740904] E [MSGID: 101176]
    [graph.c:670:glusterfs_graph_activate] 0-graph: init failed
    [2016-01-14 08:13:15.741676] W [glusterfsd.c:1231:cleanup_and_exit]
    (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x307) [0x40d287]
    -->/usr/sbin/glusterfs(glusterfs_process_volfp+0x117) [0x4086c7]
    -->/usr/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407e1d] ) 0-: received
    signum (0), shutting down
    
    Upstream reference
    -------------------
    >Change-Id: I124deda505d128eacb15ca20fbdcd1593cb8eba3
    >BUG: 1298520
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/13240
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >(cherry picked from commit ca4d4a26a553bac9c627bc6e6d6c9fa1f9435297)
    
    Change-Id: Ibe0b7e99e7125d9365d6cedf55d8649c86108b41
    BUG: 1308806
    Reviewed-on: http://review.gluster.org/13453
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Raghavendra Bhat 2016-03-04 10:57:40 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.6.9, please open a new bug report.

glusterfs-glusterfs-3.6.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2016-March/048584.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.