Bug 1298610 - Update python-networking-cisco spec to 2.0.0
Update python-networking-cisco spec to 2.0.0
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-cisco (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
Ofer Blaut
: OtherQA, Rebase
Depends On:
Blocks: 1313941 1313943 1313965 1313970 1314083 1321147 1321149 1322024
  Show dependency treegraph
 
Reported: 2016-01-14 09:51 EST by Brian Demers
Modified: 2016-04-07 17:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-networking-cisco-2.0.0-3.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 1313941 1313943 1313970 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:22:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update version and release (remove XXX from RDO version) (1.48 KB, application/mbox)
2016-01-14 09:51 EST, Brian Demers
no flags Details

  None (edit)
Description Brian Demers 2016-01-14 09:51:51 EST
Created attachment 1114835 [details]
update version and release (remove XXX from RDO version)

The current osp8 branch still has the kilo version of python-networking-cisco

In order to update to the liberty version (2.0.0),
cherry-pick the following from upstream (https://github.com/openstack-packages/python-networking-cisco/commits/rpm-liberty):
880f258bffb97d18c9e16d241f21c1642018744e
091c9ab38cf34136134c53655d1a69756d03c033

And apply the attached patch. (I don't have access to update the spec repo)

Let me know if additional updates are needed

Scratch build results: http://brewweb.devel.redhat.com/brew/taskinfo?taskID=10343207
Comment 2 Mike Burns 2016-01-14 12:59:49 EST
Looking at the rebase, it says that you need ciscoconfparse -- does that need to be a requirement?
Comment 3 Mike Burns 2016-01-14 13:05:02 EST
build done without ciscoconfparse
Comment 5 Mike Burns 2016-01-15 17:42:03 EST
The reason the build failed: 

RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/bin/fabric-enabler-agent
   /usr/bin/fabric-enabler-cli
   /usr/bin/fabric-enabler-server
   /usr/bin/neutron-cisco-apic-host-agent
   /usr/bin/neutron-cisco-apic-service-agent
   /usr/etc/saf/enabler_conf.ini
   /usr/etc/saf/init/fabric-enabler-agent.conf
   /usr/etc/saf/init/fabric-enabler-agent.service
   /usr/etc/saf/init/fabric-enabler-server.conf
   /usr/etc/saf/init/fabric-enabler-server.service

The /usr/bin entries are easy enough to fix, but the /usr/etc/* files shouldn't be going into /usr/etc.  Those are things that should probably go in /etc.  This needs to be fixed by in the package first.
Comment 6 Brian Demers 2016-01-19 12:41:05 EST
I was thinking the OSP8 branch would start from the upstream rpm-liberty, so this branch is two commits to resolve this:
880f258bffb97d18c9e16d241f21c1642018744e
091c9ab38cf34136134c53655d1a69756d03c033

How should we proceed ? Do you want separate BZ's to track a back port of each of those?  Or should I just attach a patch that contains the delta between rpm-liberty and the downstream spec repo ?
Comment 7 Mike Burns 2016-01-19 14:40:43 EST
Ahh I had missed the spec updates in stable liberty.  With those, the build works.
Comment 13 Brian Demers 2016-03-28 23:48:07 EDT
I created a patches branch on code.eng 'rhos-8.0-patches'  This can be applied to the spec repo with `# patches_base=+2`, please review the branch and apply.

The first one updates the .gitreview to stable/liberty, the second for code.eng

We were going to cut a new release from stable/liberty, but given the uncertain stadium policy (and short time frame) we created a patches branch (all changes have been merged to master, and proposed to stable/liberty on review.openstack.

I'll update the referenced blockers above in the morning.
Comment 15 errata-xmlrpc 2016-04-07 17:22:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.