Bug 1298628 - perl-DBD-SQLite-1.48-2.fc24 FTBFS: t/virtual_table/21_perldata_charinfo.t test fails with sqlite 3.10.0
perl-DBD-SQLite-1.48-2.fc24 FTBFS: t/virtual_table/21_perldata_charinfo.t tes...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-DBD-SQLite (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
: Reopened
Depends On: 1296758
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 10:19 EST by Petr Pisar
Modified: 2016-02-20 21:21 EST (History)
5 users (show)

See Also:
Fixed In Version: perl-DBD-SQLite-1.48-3.fc24 perl-DBD-SQLite-1.48-3.fc23 perl-DBD-SQLite-1.46-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 21:21:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-14 10:19:47 EST
perl-DBD-SQLite-1.48-2.fc24 fails to build in F24 because tests fail:

t/virtual_table/20_perldata.t ......................... ok
couldn't eval q{sub {my ($self, $i) = @_; my $row = $self->row($i); (defined($row->{script}) && defined($vals[0]) && $row->{script} eq $vals[0]) && (defined($row->{name}) && defined($vals[1]) && $row->{name}  $vals[1])}} : syntax error at (eval 13) line 1, near "}  $vals"
#   Failed test 'no warnings'
#   at inc/Test/NoWarnings.pm line 38.
# There were 1 warning(s)
# 	Previous test 3 'create table'
# 	Use of uninitialized value $op in concatenation (.) or string at /builddir/build/BUILD/DBD-SQLite-1.48/blib/lib/DBD/SQLite/VirtualTable/PerlData.pm line 98.
#  at /builddir/build/BUILD/DBD-SQLite-1.48/blib/lib/DBD/SQLite/VirtualTable/PerlData.pm line 98.
# 	DBD::SQLite::VirtualTable::PerlData::BEST_INDEX(DBD::SQLite::VirtualTable::PerlData=HASH(0x20271b8), ARRAY(0x20272f0), ARRAY(0x2027548)) called at /builddir/build/BUILD/DBD-SQLite-1.48/blib/lib/DBD/SQLite.pm line 202
# 	DBD::SQLite::db::prepare(DBI::db=HASH(0x20078e0), "SELECT * FROM charinfo WHERE script='Greek' AND name LIKE '%S"..., HASH(0x202a000)) called at /usr/lib64/perl5/vendor_perl/DBI.pm line 1669
# 	DBD::_::db::selectall_arrayref(DBI::db=HASH(0x20078e0), "SELECT * FROM charinfo WHERE script='Greek' AND name LIKE '%S"..., HASH(0x202a000)) called at t/virtual_table/21_perldata_charinfo.t line 42
# 
# Looks like you planned 10 tests but ran 4.
# Looks like you failed 1 test of 4 run.
# Looks like your test exited with 2 just after 4.
t/virtual_table/21_perldata_charinfo.t ................ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 7/10 subtests 

Difference between working and failing build root is:

        sqlite-devel 	3.9.2-1.fc24 	> 	3.10.0-1.fc24
	sqlite 	3.9.2-1.fc24 	> 	3.10.0-1.fc24
	glibc 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	glibc-common 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	glibc-devel 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	python3-libs 	3.5.1-2.fc24 	> 	3.5.1-3.fc24
	gnupg2 	2.1.10-1.fc24 	> 	2.1.10-3.fc24
	redhat-rpm-config 	36-1.fc24 	> 	39-1.fc24
	coreutils-common 	8.24-105.fc24 	> 	8.24-106.fc24
	kernel-headers 	4.4.0-1.fc24 	> 	4.5.0-0.rc0.git1.1....
	python3 	3.5.1-2.fc24 	> 	3.5.1-3.fc24
	glibc-headers 	2.22.90-27.fc24 	> 	2.22.90-29.fc24
	python-srpm-macros 		> 	3-4.fc24
	coreutils 	8.24-105.fc24 	> 	8.24-106.fc24

This is caused upgrading sqlite to 3.10.0 and upstream provides a testing release 1.49_05 with needed adjustments.
Comment 1 Petr Pisar 2016-01-15 04:01:23 EST
I will apply upstream patches healing the failure. All Fedoras are affected because sqlite was rebased everywhere.
Comment 2 Petr Pisar 2016-01-15 04:13:19 EST
The new sqlite-3.10.0 is not yet in F23--22 build roots. Because the fix is included at build-time, we have to wait with building perl-DBD-SQLite.
Comment 3 Fedora Update System 2016-01-18 02:35:27 EST
perl-DBD-SQLite-1.48-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-745ec448de
Comment 4 Fedora Update System 2016-01-19 22:55:30 EST
perl-DBD-SQLite-1.48-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-745ec448de
Comment 5 Fedora Update System 2016-01-28 13:29:42 EST
perl-DBD-SQLite-1.48-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-02-10 07:11:54 EST
perl-DBD-SQLite-1.46-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5a27ff0c1
Comment 7 Fedora Update System 2016-02-11 09:53:26 EST
perl-DBD-SQLite-1.46-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5a27ff0c1
Comment 8 Fedora Update System 2016-02-20 21:21:53 EST
perl-DBD-SQLite-1.46-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.