Bug 1298664 - Please respond
Please respond
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python-pymongo (Show other bugs)
rawhide
All All
unspecified Severity high
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 12:09 EST by Randy Barlow
Modified: 2016-01-14 14:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 14:49:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-01-14 12:09:01 EST
The maintainer of pymongo seems to have been absent for quite some time. There is one severe issue that has been filed for a while against pymongo that has not gotten attention:

https://bugzilla.redhat.com/show_bug.cgi?id=1294130

pymongo does not work at all with Python 3, and it is a packaging problem and not an upstream issue.

Additionally, there have been other releases of pymongo that are available upstream that are not getting packaged for Rawhide:

https://bugzilla.redhat.com/show_bug.cgi?id=1294131

Additionally, though this bug was fixed, it was fixed by a provenpackager and not by the maintainer:

https://bugzilla.redhat.com/show_bug.cgi?id=1210043

I am the maintainer of python-mongoengine which uses this package, and I am also the maintainer of Pulp which uses both python-mongoengine and python-pymongo. We need this package to be actively maintained.

I am willing to help out, if you will approve my request for commit/administration ACLs:

https://admin.fedoraproject.org/pkgdb/package/rpms/python-pymongo/

My FAS account is rbarlow. Thanks!

[0] https://fedoraproject.org/wiki/Package_maintainer_policy#What_to_do_if_a_maintainer_is_absent
Comment 1 Andrew McNabb 2016-01-14 13:23:26 EST
Hi. I'm happy to have the help. I'm not an active pymongo user, so I'm not following these issues as well as I probably should. (I mainly stepped in in the first place because no one else had stepped up.)
Comment 2 Fedora Admin XMLRPC Client 2016-01-14 13:24:16 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Randy Barlow 2016-01-14 14:49:19 EST
Thanks to Aaron, I am able to solve these issues now!
Comment 4 Randy Barlow 2016-01-14 14:49:47 EST
Ahhh sorry, Andrew, not Aaron! Thank you Andrew!

Note You need to log in before you can comment on or make changes to this bug.