Bug 1298709 - Self Service : Validation message keeps on showing even after navigating to other pages
Self Service : Validation message keeps on showing even after navigating to o...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Aparna Karve
Shveta
ssui
: ZStream
Depends On:
Blocks: 1302889
  Show dependency treegraph
 
Reported: 2016-01-14 14:06 EST by Shveta
Modified: 2016-06-29 11:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302889 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:30:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
err (64.52 KB, image/png)
2016-01-14 14:06 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2016-01-14 14:06:16 EST
Created attachment 1114925 [details]
err

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a user with role approver and login to self service UI
2. try to submit an order request for service catalog 
3. Validation message is shown because of no permissions to order .
4. Now click on any link or any other page , validation message keeps on displaying

Actual results:


Expected results:


Additional info:
5.5.0.13.20151201120956_653c0d4
Comment 4 CFME Bot 2016-01-28 13:21:09 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/94fd2a4d627e74d60d54e7f6e550e707cb9902d8

commit 94fd2a4d627e74d60d54e7f6e550e707cb9902d8
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Wed Jan 27 08:48:11 2016 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Wed Jan 27 08:48:37 2016 -0800

    Clear Validation messages when user navigates to other areas in the UI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1298709

 spa_ui/self_service/client/app/states/requests/list/list.state.js | 6 +++++-
 spa_ui/self_service/client/app/states/services/list/list.state.js | 7 ++++++-
 2 files changed, 11 insertions(+), 2 deletions(-)
Comment 5 Shveta 2016-04-17 16:01:09 EDT
Fixed .
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 7 errata-xmlrpc 2016-06-29 11:30:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.