Bug 1298745 - Public interface for RHCI's and RHCS-I OOO ISO's default to eth0
Public interface for RHCI's and RHCS-I OOO ISO's default to eth0
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: ga
: 1.0
Assigned To: John Matthews
Thom Carlin
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-01-14 17:14 EST by Thom Carlin
Modified: 2016-09-13 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1298268 None None None 2016-01-14 17:14 EST

  None (edit)
Description Thom Carlin 2016-01-14 17:14:44 EST
Description of problem:

Installing ISOs on systems with public (external) interface that are not eth0 require boot menu changes

Version-Release number of selected component (if applicable):

TP2

How reproducible:

100%

Steps to Reproduce:
1. Install ISO on system with public interface on eth2
2. When fusor*-installer comes up, examine fields

Actual results:

fields are blank and hostname = localhost.localdomain

Expected results:

Populated fields (including hostname)

Additional info:

External bz (1298268) is workaround.

Poor UX
Comment 1 Jason Montleon 2016-06-21 15:35:23 EDT
We no longer start any interfaces since enabling consistent network names. Further our design diagrams suggesting having the OOO and QCI hosts attached to a single routed network. In a case where that suggestion isn't followed the user may have some additional setup to do, but essentially no interface is different from another now.
Comment 2 Thom Carlin 2016-06-28 13:58:23 EDT
In QCI 1.2:
Verified no interfaces are started after either ISO
Verified consistent network names are now being used (no ethx)

Moving to VERIFIED
Comment 8 errata-xmlrpc 2016-09-13 12:24:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.