Bug 129881 - RFE: Jump to details mode or give more textual feedback when fsck check is forced due to check interval expiration
RFE: Jump to details mode or give more textual feedback when fsck check is fo...
Status: CLOSED DUPLICATE of bug 107121
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-13 15:06 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2004-08-13 15:06:07 EDT
Description of problem:
Let's say i have a /home partition where Check interval
as listed from tune2fs -l is set to 180 days,

I reboot at 181 days and fsck at boot does a check of the parition,

rhgb  will sit there in graphical mode without any feedback as to what
is going on. This is definitely a case where an average user might
think the boot process is stuck..churning harddrive... and reboot.

I understand that check interval isnt set for fedora installed
partitions, but people do have secondary disks with paritions created
by other means and other distributions even. So its not inconcievable
that I'm the only person whose going to run into this. In fact the
partition im using that triggered this was created from a rh 7.3
install, and i just moved the disk which is all storage into a new fc2
box.

How reproducible:
Everytime i've let the check interval expire.
set a short check interval via tune2fs and reboot after the interval
has expired... watch in horror as rhgb doesn't jump to details view
as fsck forces a check of the partition.

  
Expected results:
Either:
1) rhgb jumps to details view so you can see the text message from
fsck about the forced check

or 

2) some verbosity in rhgb's graphical text strings about whats going
on and why, while i wait for the harddrive light to stop flickering
like a sputtering candle.
Comment 1 Daniel Veillard 2004-09-15 13:47:37 EDT
Already adressed in #107121, rhgb-0.13.1 and a fix to initscripts 
should really improve this,

  thanks,

Daniel

*** This bug has been marked as a duplicate of 107121 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.